Microsoft Access triggers install of Palm Treo software- caught by Defense+

I have just upgraded to V3 with Defense+.

It seems that the Palm Treo installation software is not recognized by Defense+ and so it raises an alert and places 15 files pending review. These files are all run from the Temp directory, have no company name and have a status of either new or new/modified. As far as I can ascertain from searching the Web all the files are either part of the Palm software or InstallShield. The alert raised is that IDriver.exe is about to create a new file/folder C:\Windows\Sysrem32\EmptyFile.txt

The curious thing is that every time I run a specific piece of code in Microsoft Access, the Palm Installation software is triggered! The Palm software (HotSync Manager and Desktop) was installed and functioning before the upgrade to version 3. Both the Palm Desktop and the HotSync Manager continue to work, so why is an installation being triggered? This seems very suspicious to me.

Nothing happens if I run this Microsoft Access code on a machine without the Palm software.

The code in Microsoft Access is:
Dim cbc As CommandBarControl
Set cbc = CommandBars.FindControl(ID:=866)

It is necessary to set a reference to the Microsoft Office 11 Object Library first.

If this code is run in debug mode, it becomes clear that control does not return to MS Access until the installation has been cancelled.

I use AntiVir (which is pretty picky about what it allows) for virus scanning and it show nothing.

I hope that someone can help.

  • Why is this happening?
  • What can I do to get rid of the annoyance of killing the installation every time I run the code

What other code have you got there? Anything like this?

Dim cbc As CommandBarControl
Set cbc = CommandBars.FindControl(ID:=866)
Set cbc = Nothing
End Sub

Also, have you used an option explicit statement?

No, there is no cbc.Execute and yes there is an option explicit in the code.

I solved the problem by simply uninstalling the Palm software and re-installing it. Curious to say the least. I suspect that it may be time to do a clean reinstall of the OS, it has been running for 4 years now which is close to a record for me.