micro-freezing

my comodo dragon seems to do a “micro-freeze” every so often (a micro-freeze being 10 or so seconds of all web pages not responding then they quickly do all the input you gave them e.g. scrolling)

My specs:
AMD Athlon II 4450e @ 3.5GHz
ASRock N68-VS3 FX - Latest BIOS
XFX NVIDIA GTX 285 Black Edition
SeaGate 1TB HDD
Windows 7 Professional 64 Bit

Thank you for looking and I hope you know the answer to my problems

Hi ganon11000,
I have not experienced this issue, but I will take a stab in the dark.
Try disabling ‘Use hardware acceleration when available’, found at the bottom of the ‘Advanced Settings’.

If that fails try disabling your extensions.

Kind regards.

believe it or not it has not done it in the past few days … after the nvidia driver update so I guess that was causing this issue.

That is good to hear, let us hope it continues behaving.
Thanks for letting us know. :-TU