mHotspot (turn laptop into WiFi hotspot)

Hello! So I’m trying to turn my laptop into WiFi hotspot for my tablet. Finally it worked with the program mHotspot. However it only provides Internet on the client device when Comodo Firewall is set on “disabled”. If it’s in “Training mode”, the Internet stops immediately on the client. I’ve added the relevant IP addresses to trusted zones in Comodo Firewall and I’m checking what kind of requests and connections does the client use and allow them, however so far it doesn’t work.

So, of course, I could just disable Comodo Firewall whenever I’m using WiFi Internet on my tablet, but that seems pretty risky and sometimes that could be a fairly long time, not just 15 minutes. So does anyone know how to make the Internet on the client of mHotspot work even when Comodo Firewall is active (in Training mode)?

A bit of update. So I realized that “Network Intrusions” in Comodo Firewall does show me every single blocked packet by the firewall. It turns out - not surprising - that anything sent from my tablet (the client) to my laptop (the mHotspot server) is blocked. The problem is I don’t understand why this is happening. I have added Global Ruleset that should allow any In/Out requests on any port, TCP/UDP, when sent from the IP of my tablet. Also the entire subnetwork of the two computers is added as a Home Zone and there are also global rules that any requests with IP in dest/source from any Home Zone should be allowed. I’m very confused why Comodo Firewall ends up blocking all those packets. I’ve usually set the firewall to Training Mode; now I even tried Custom Ruleset to check if that helps, but it doesn’t.

Okay, so after monitoring all packets with Wireshark, I tried the following radical testing - added the global rule:

Allow And Log IP In/Out From MAC Any To MAC Any Where Protocol Is Any

Which means when the firewall is turned on - no matter the mode I believe (I put it on Training) - it’s as if it’s off. It should allow everything!

But that still doesn’t help. The home network doesn’t work. Only works when the firewall is really set to off. So at this point I’m very confused with Comodo. Does it have other internal rules that override the global rules? And why would that interfere so much with a home network?

Global rules alone won’t get you very far, there has to be an application listening for the incoming traffic otherwise its considered unsolicited traffic and dropped by the windows operating system.

You’ll also want to look at any Comodo Firewall threads that reference internet connection sharing, since mHotspot looks like it uses connection sharing.

As I don’t use either I can’t be of any further assistance.

Hello i am also facing the same problem. I cant run mhotspot with comodo firewall. what i am doing now is i have changed firewall security level to disabled from safe mode and able to run mHotspot. The problem with this setup is that i am unable to run comodo firewall while running mhotspot. Can you please tell me how i can correct this problem and i am not a computer geek.


Seems like I had the same problem until now. I always use custom ruleset, seems to be safer. Now the culprit behind mhotspot is ‘svchost’. What I would suggest is delete all custom rules and apply again one by one, and when you open mhotspot, comodo should prompt for ‘svchost’ access approval. Go ahead and treat as allowed application. This should help!