[Merged] context menu scan unresponsive

i have installed the latest cis 6.2.282872.2847, everything working fine except right click context menu scan, whenever i try to scan a folder or a single drive by right click “scan with comodo antivirus” nothing will happen. help me please. i am a user of cis 5.
Mod edit: Added merged to the topic title, Captainsticks.

Hi and welcome prsnjt.paul,

Did you do a clean install or an update?

Do other manual scans operate?

Thank you.

yes sir, i did a clean install. other manual scans are working perfectly. only problem i have encountered is the context menu scan. the older version(cis 5) work correctly.

I have asked the other Mods to take a look at this topic, in case they have come across this before or know of a solution.

Thank you.

The regsvr32 “%ProgramFiles%\COMODO\COMODO Internet Security\cavshell.dll” command is to replace the scan entry in the context menu if it is missing.

You have the context menu entry to ‘Scan with COMODO Antivirus’ but it is not functioning, correct?

Edit: Umm I guess you deleted the post I was answering? ;D
Edit2: Added missed quotation mark, thanks for pointing this out Eric.

yes i deleted the post because this is irrelevant to the problem. as i have “scan with comodo antivirus” in the context shell. but it do nothing when clicked.

Can you look up the shell extension setting with Sysinternals Autoruns or similar tool and post it here?

It is not clear from your post if you are using v5 or v6.

sir i m using cis from last 2yrs . previously i have cis 5 in my machine & everything works well. now i installed cis 6.2.282872.2847(latest) to avail the new features included by COMODO. i just faced one problem i.e, right click issue(scan not started by right click ). no i have not revert any autorun setting.

here is the sysinternals autorun report.

[attachment deleted by admin]

Did you try captainsticks suggestion to use the command line to register it to the shell?

I noticed he forgot the quotaion mark at the end. The command reads: regsvr32 “%ProgramFiles%\COMODO\COMODO Internet Security\cavshell.dll”

Sir i have already tried it earlier, register n unregistering to context menu handler. But the prob is diffrent and its already there in the context menu.

Please look into it n resolve quickly. Is it a bug?

Did you try the command line as I posted it? It has a fix.

Thanks Eric, I have now corrected the offending post.

yes. run cmd as admin then type the above line, succeed but no results as it already there in the context menu. you don’t get my problem properly. its already there in the context but when i click to scan nothing happen.

Hi prsnjt.paul,
My suggestion here might be a pain, but sometimes persistent issues are resolved quicker by doing a fresh re-install.
Moderator Chiron has posted a guide in the link below that has cured problems for many users.
Most Effective Way to Reinstall/Update CIS to Avoid/Fix Problems
Keep us informed.
Thank you.

i have already done the steps as mentioned by chiron & jacob… no results… i do a lot of research and tried hard to solve it when failed then posted in the forum need you guys help afterall its your product…
cis 5 works well… after releasing cis 6 , i have installed it on mine & different mc running win xp n win 7(x86) n win 7(x64)… same problem… then get back to the cis 5 again. now after releasing the latest ver with quick view panel, i give it another try hoping it will work, but same cavshell problem.

now again will get back to cis 5 :embarassed:

i am a software engineer ;D

This is unusual to be happening on a number of systems for you.
I do wonder what/if there is a common conflicting factor on all of your systems you have tried.
I am sorry this issue is not resolved and the only other thing I can suggest is to create a bug report in the hope that Developers can reproduce the issue.
If you decide to post a bug report, please follow the guidelines.
Bug Reports
Bug Report Guidelines
Thank you, your time and effort with this issue is appreciated.

BTW: Just to be clear it is not my product, this is a community based Forum and I am an end user like yourself. :slight_smile:

thank you for your time also…
pardon me, i thought you as comodo’s help desk executive :slight_smile:

You are welcome.

pardon me, i thought you as comodo's help desk executive :)
Apologies if the Moderator title misled you. Moderators are end users who volunteer their time to help keep the Forum in order. Moderators like other General members, do try help solve issues to the best of our knowledge. Sorry we have not not succeeded with this issue, if you do have the time to file a report we can then forward it to the Developers.

Thanks again for your time and effort. :-TU
Kind regards.