[Merged]Anti-Virus Not updating

Hi there,

I’ve installed Comodo on numerous computers and it has been working perfectly!
All the people’s computers i’ve put it on have ranted and raved about it and some of them have even purchased toe full versions they have enjoyed it so much.

Personally I had been using Kapersky until today and the slowness of it was ticking me off.
So I thought. Why not just install Comodo?

Anyway I just went to the downloads website and installed it as I have been doing on all the other computers.
Internet Security.

It installed fine, I allowed the most of the things that I need and then I encounted my problem

It will not update! ???

I went through numerous threads trying the things they said to do such as

  • un-installing and reinstalling
  • deleting the Windows/Temp folder
  • running cmd and deleting the Temp folder that way (it deleted alot of files :S )
    -re downloading and reinstalling

No matter what I’ve tried it’s just not working and I’m getting pretty frustrated. Also I went to try and play one of my favourite games to release some frustration and it simply will not function. It was working fine several hours ago and it had to be some of the work of Comdo somewhere down the line. But I fixed that anyway.

I thought. Hmmm I’ll use this Geek buddy feature they rant and rave about.
So I installed Geek Buddy. It says that it needs to update and it closes itself automatically.
Hmm so I went to the Comodo website and found a newer version of Geek Buddy.
Installed it and the same thing happened.

With all hope lost I’ve gone to the forums in search of some help.
Please help me update my data base!

PS when I click update it goes to 5% then tells me that it failed to connect to the internet while I can clearly connect to the internet.


Hello Giga,

Please Visit This Page
Follow The Instructions Can Be Located Here

Also; Do you have any other security software installed?


Hi Jacob,

I’m downloading it as we speak and I plan to follow the instructions.

I just have a question.

After I do this will I have to constantly download a new bases.cav file or is this a fix to the solution?
And no I do not have any other security software installed.


Thank you for a quick response;

This sometimes on most occurrences will fix the problem that you are expierencing

Sometimes it takes all "Uninstalling/Use Removal Batch/restart in safe mode/Use removal batch as well as the temp folder located in ‘windows’/restart in normal mode/ use removal batch also remove temp files in %temp% and verify that all parts of CIS are gone)


Thank YOU! For your quick responce Jacob,

This is what I just did and I am still experiencing the same problem

I went to
C:\Program files\Comodo\Comodo internet security\scanners
Renamed the current bases.cav file to bases.old (obviously incase something goes wrong with original I’d assume)

Then I just placed the new bases.cav file there.
I rebooted the computer, pressed up date the problem was still there.

Hope you can help! Thankyou

PS I am not sure what this ‘removal batch’ is or how i can ‘verify that all parts of CIS are gone’

Ok; Lets Try This? (This will take about 20 minutes)
Download this

Create a Restore Point^ > Uninstall CIS > Restart in Safe Mode (Tap F8 After Manufactor Logo Disapears > Safe Mode > Log Into Admin account) > Run the batch file (Also remove windows temp* folder) and Remove Temp Files** > Restart in Normal Mode > Run the Batch File Again > Download/Install CIS Once Again; Once Reinstalled Restart, Then Try to update

^ start > programs > system tools > system restore > create a system restore point

  • start > programs > acc > right click run as admin > command prompt >
    del /f /s /q %temp%
    ** start > programs > acc > right click run as admin > command prompt
    cd %systemroot%
    rd /s temp
    md temp

Also; CIS > More/Misc > Diagnostics
Does this report anything?

Last but not least (Could you follow the following link instructions)


The same problem . . . . .

Thanks for all your effort by the way!
Um I did the diagnostics report and it was all fine.

Should I re download the base.cav file and try that??

other than that i’ve pasted the report into the paste bin link (so to not cause clutter in the thread)


hope you can help Thanks again Jacob!

For troubleshooting purposes;

Are you using a proxy? or any other ‘special’ Networking Variable?
Also; if you go to start > prog > acc > command prompt
ping download.Comodo.com
Do you get results back?

Also While at the command prompt
enter the following commands
ipconfig /release
ipconfig /flushdns
ipconfig /renew
Then try to update the AV

Also; CIS > Firewall > Firewall Behavior Settings > Advance> Uncheck ‘Block Fragmented IP Datagrams’
see if this helps

You may try the downloading of the DB and try again.

Thank you for your patience :slight_smile:


Thanks again Jacob.

I could ping the download server fine.
I Flushed my ip
I unchecked BLock Fragmented IP Datagrams

Still the same error is occuring ???

I’m not using a proxy

Also the ONLY ‘special’ network variable that I could possibly think of is the switch that I connected the other day. It improved my internet speed and hadn’t affected anything else. But that was changed a while ago and i’m sure that won’t be affecting the problem at all.

Were running low on ideas but I think I know of something that may make it work.
Thanks for helping Jacob!

I still wonder what the problem could be.


I have asked other moderators to come assist you;

This could be a bug;
(Expect a reply within 48 hours)

Sorry that i couldn’t be of an assistance.


Thanks for your help Jacob!

You did a still did a great job! I am grateful for your help!

Also what I did, it didn’t work either!
Thanks for forwarding this problem also!

Hi all Moderators

I am having exactly the same problem despite following all the “fixes” suggested in this string (including uninstalling, re-downloading, and re-installing CIS at least 3 times).

From the number of times this string has already been viewed, and previous posts canvassing the same topic, it seems a lot of other users are having the same problem.

It’s all very well making your software free (and much appreciated), but how about making it work? :frowning:

Hope to see a real fix soon, thanks, Oska.

Hi Oska,

It’s a free program and were not paying for their services!
Still, we should be thankful these moderators have been going out of their way to help up.

Seeing as this problem has happened to varous people it may be a bug of some description and every program has bugs. It’s just a matter of finding out what the problem is and how to solve it.

Let’s keep our fingers crossed :slight_smile:

Hi All,

Had the same problem but fixed it look go to
and scroll to the end to see how I fixed mine could be the same problem.

Hi Thomlin,

Thanks for your help but I don’t have any process named pisa and sua.

What version of CIS are you running?

also on the same screen as the version number, For “Virus Signiture Database Version” What number is it??

Are you using a proxy?

Did you install it from an older one, like going from CIS version 3.14 to CIS 5.3 (something like that)

Hi Jay,

The version of CIS that I am running is 5.3.176757.1236 .
My virus signature database is 1.
and I am not using a proxy.

and didn’t install it from an older version I just downloaded the new version off the Comodo website and installed it (assuming the version of the Comdo website would be the latest)

The version of CIS that I am running is 5.3.176757.1236 . My virus signature database is 1. and I am not using a proxy.

and didn’t install it from an older version I just downloaded the new version off the Comodo website and installed it (assuming the version of the Comdo website would be the latest)

intreasting, I trying to think, what would prevent you from updating ???
I’ll PM Ronny on this issue, he’s better then me. We WON’T ignore you, I promose :slight_smile:

Hi, I’m back.
I am also running CIS 5.3.176757.1236 following program update. (I previously had whatever the preceeding version 5 number had been by download from Comodo website.)
After that update the VSDB showed v1 (which seems odd), but having done the download latest bases.cav fix on 26-01-2011 the ‘More/About’ dialogue now shows DB v7448.
I am also using Comodo GeekBuddy v3.1.0.0.
My OS is Win.XP.sp3, 32bit Home Edition, version 5.1 (build 2600.xpsp_sp3_gdr.100427-1636).
My internet connection is by ethernet cable to broadband router. I am using the Comodo DNS servers, but am not using a proxy.
Whenever, and however many times, I click on either VSDB ‘Update Now’, or ‘Never Updated’, or ‘Update Virus Database’ links (in each of the main CIS dialogue left-hand column, the summary tab dialogue, and the Antivirus tab dialogue) I alsways get zero update with the error dialogue “Failed to update the virus signature database. Please check your internet connection and try again later.”
My internet connection is fine (otherwise I couldn’t get here!). The CIS program update checker, under the ‘More’ tab, works properly.
So the VSDB update problem seems to be a programming bug, which is truly a shame because it is a serious detraction from CIS that in all other respects I would recommend on software distribution websites.

Glad to know. Hope this ‘Ronny’ person can help me.
Regardless :slight_smile: thanks for your help