Memory problems regarding Defense+

A. The bug/issue

  1. What you did: I tried to run an app (specifically Project64k, latest version)

  2. What actually happened or you actually saw: Memory problems when app is executed, goes away when Defense+ is fully disabled under options/guard32.dll is disabled.

  3. What you expected to happen or see: The application would open without errors or warnings.

  4. How you tried to fix it & what happened: Extensive attempts to resolve with a mod, documented in this post.

  5. Details & exact version of any software (except CIS) involved (with download link unless malware):
    The application is an online version of a famous gaming console emulator. It’s offline (normal) 1.6 version works, however the online version of it does not. (Mod edit: also the version 1.5 downloadable version does not work)

Download link: pj64k

  1. Whether you can make the problem happen again, and if so exact steps to make it happen:
    Set Defense+ to any mode, except disabled, and run the app. It should return you the following errors:
    “Not enough memory for jump table!”
    “Failed to allocate memory”

  2. Any other information (eg your guess regarding the cause, with reasons):
    All I’m sure is that it’s related to CIS. Uninstalling it solved. Disabling D+ completely also made the app work again.

B. Files appended:

  1. Screenshots of the Defense plus Active Processes List.
  2. Screenshots illustrating the bug.
  3. Screenshots of related CIS event logs.
  4. Screenshot of More~About page.

C. Your set-up

  1. CIS version, AV database version & configuration used:
    On attached screenshot.

  2. a) Have you updated (without uninstall) from from a previous version of CIS: No.
    b) if so, have you tried a clean reinstall (without losing settings)?: Yes.

  3. a) Have you imported a config from a previous version of CIS: Yes.
    b) if so, have you tried a standard config (without losing settings)?: Yes.

  4. Have you made any other major changes to the default config? (eg ticked ‘block all unknown requests’, other egs here.): No.

  5. D+: Safe Mode; Sandbox: Enabled; Firewall: Safe mode; AV: On Access.

  6. OS version, service pack, number of bits, UAC setting, & account type: Windows XP Professional, SP3, 32bit, (no uac), Administrator. [Mod edit: My (mods experience is that it works OK on Win7 Vmware VM, fails on Win XP VM)].

  7. Other security and utility software currently installed: USB Disk Security, CCleaner, Daemon Tools.

  8. Other security software previously installed at any time since Windows was last installed:
    Avast! AV, MalwareBytes Anti-Malware.

  9. Virtual machine used:

[attachment deleted by admin]

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again