Memory leak in cmdagent.exe + github [M1434]

A. THE BUG/ISSUE cmdagent.exe memory usage (private bytes/working set) increase until all RAM exhausted when Windows desktop program Github for Windows is started. Eventually windows crashes unless I reboot.
Can you reproduce the problem & if so how reliably?:
Yes, every time.
If you can, exact steps to reproduce. If not, exactly what you did & what happened:
1:Comodo CIS (free) version 8.1 installed and running
2:Start win program github.exe from a desktop shortcut
One or two sentences explaining what actually happened:
Once github.exe is started, cmdagent.exe begins taking more memory resources per Windows resource monitor (committed, working set). About 2 Mb per sec. This continues after closing github,exe, or letting it continue to run.
One or two sentences explaining what you expected to happen:
cmdagent.exe should remain around 30 Mb of committed memory.
If a software compatibility problem have you tried the advice to make programs work with CIS?:
Any software except CIS/OS involved? If so - name, & exact version:
Yes. Github for Windows (github.exe) distributed by
Any other information, eg your guess at the cause, how you tried to fix it etc:

Exact CIS version & configuration:
Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
Firewall safe mode HIPS disabled Autosandbox disabled
Have you made any other changes to the default config? (egs here.):
Have you updated (without uninstall) from CIS 5, 6 or 7?:
if so, have you tried a a a clean reinstall - if not please do?:
Have you imported a config from a previous version of CIS:
if so, have you tried a standard config - if not please do:
OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
Win 7 x64 Pro sp1, UAC is first level above “off” (notify without dimming) account is in administrators group
Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
a=none b=none

Always attach the diagnostics file (instructions on how to do this provided here) and the KillSwitch Process List (instructions on how to do that provided here and put the resulting file in a zip file. Both should then be attached to your post.
Note that additional information may be requested by the processing Moderator.

[attachment deleted by admin]

Please provide :

  • link to mentioned application/sample
  • a full dump of ‘cmdagent.exe’ process taken with KillSwitch

Thank you.

download page for github for windows is here:

direct link to installer is here:

I have a dump file but zipped it is 50MB and can’t attach it. I could post to dropbox or if you have prefferred location.

scott s.

A reliable link, if possible. Dropbox sounds fine.
Note : Make sure it’s a full dump.


Here is the link to on my dropbox

scott s.

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Similar issue here since March 2nd. Any workaround to deal with this issue until it get resolved?

The only way I can think of is to uninstall comodo…


I’m experiencing the same problem with my system only I’m not using GitHub, so I think that it is a general problem in the firewall that occurs with any program that uses the network.
I have to reboot my system about every 10-15 days because Windows 7 can no longer supply memory to other processes because all of my 16 GB was in use.

I’ve enabled the firewall module and the HIPS+ module and am running Windows 7 x64. Comodo is at version

I’ve disabled UAC.

I’ve also dumped the contents of cmdagent.exe using KillSwitch. Since the file is over 175 MB large (because the exe is using over 3 GB of memory now) I’ve put it in dropbox where you can access it using the following link => Dropbox - File Deleted - Simplify your life

Let me know when I can remove the file again.

I’ve updated tracker data: linked your post in the tracker.


FYI: The memory leak problem still occurs with the new version of CIS.

Has there been any progress regarding this issue? It’s been almost 6 months since this was reported for the first time and it still is present in the current version of CIS. I know that memory leaks are tricky to find without the proper tooling, but I’d expect at least some progress regarding this issue.

I’ve asked Buket to check if there’s anything new. At the moment, I have no information. Sorry.
Make sure that you’re experiencing the same issue mentioned in the report. You could create another one if it’s not the same. :slight_smile:

Thank you.

I’m not seeing a memory leak while github is running or after closing github. Resource monitor of cmagent shows a commit size of ~27MB and a working set at most of ~15MB then drops to ~10MB when exiting github. Tested with

This is not a problem that shows up after a few network actions, but requires lots of network traffic over a longer period of time. On my system (with 16GB of RAM) I start noticing the detrimental effects after about 8-10 days of continuous use, when the amount of memory in use by cmdagent.exe starts to run in the multiple GB’s.

My guess is that cmdagent.exe accumulates small memory allocations that are not freed over time into this gigantic block of memory that it uses. Since I can’t restart cmdagent.exe (unlike the Asus motherboard support tools that have a known memory leak, which I can “reset” by restarting the associated services) without rebooting the system, I’m forced to reboot after about 10-13 days.

Most of the time another update forces me to reboot my system sooner than that, but I’ve run into “out of memory” situations as well.

So if you want to check for this issue, you need to run a network intensive program (something that is moving gigabytes of data via the network), preferably using many connections (since I think this is connection count related and not amount of data transferred) over an extended period of time. Without rebooting your system during the test!

Please check with version thanks.

Initial issue seems fixed. I will move this one to “Resolved” section.

[at]PJK, if you’re still experiencing it please create a new bug report. Modified title for better tracking.

Thank you.