maybe a bug or is it just me

Hi Everyone,

First of all i use vista 32
firewall security custom policy mode
defense + clean pc
Comodo firewall last build

I use Comodo firewall more than a year now and never had problems
To make a long story short i tell my little problem
three months ago i bought a iphone so i had to install itunes but when installed it it didnt work
it missed some files as bonjour/mDSNRREPONDER file i have always the firewall settings like above
i tried everything but nothing did help. so i shutdown the firewall and installed itunes again and itunes installed perfectly. and i did it everytime there was a update from itunes.

Till three days ago there was a software update from itunes for the iphone itself but everytime i got error -3259
when i tried to download it. yes it downloaded it but when it finished i got that error so i searched what that code means you can read it here Resolve issues between iCloud for Windows or iTunes and third-party security software - Apple Support
so i shutdown the firewall again and tried it again and again i got that error then i uninstalled the firewall and tried it again but still that error so i thought it was a mistake from itunes and installed the firewall again .

did tried yesterday again 5 times but still that error tried today 4 times but everytime that error
till i thought i disable defense+ and disable the firewall and so i did and yes it downloaded and istalled it fine.

so i had the same problems with quicktime couldnt even install it but this time i disabled defense + and yes i could install it but the player doesnt work, on some webpages i can see movies but on apples page not

so i had always problems with the install of microsoftsoft silverlight and yes i disabled defense+ and it works

so can that be a bug in defense + that it block files without prompt me or is it just me
and yes i always switched to installation mode while installing something.

greetz marcel


Do you have windows firewall enabled?

Also, Try to add iTunes as a Trusted Application in Defense (And Firewall)
Does this solve your Issue?


I had a similar problem with Defense plus blocking without notifying me. This problem started when i uninstalled comodo 3.0 and installed 3.5 In 3.5 defense plus gives you three options of install with the default at optimum (middle option). When i had it at this setting it was blocking without prompting. However, after i reinstalled comodo firewall with defense plus set to maximum (third option) the problem was gone.

I think option 2 (optimum setting) blocks some stuff without notifying.

no windows firewall is not enabled

and yes itunes is an trusted application in both

and viper i have it at maximum (third option) thx for reply