Massive Ping Spikes/Packet Drops

Well, I’ll make this as short as possible seeing as it’s already 5 am and I’m on the verge of pulling my hair out. I’m connected through a WISP, which is a wireless ISP (Frontiernet). Seems like the speeds are great except for the ping spikes I’ve been experiencing. I’m not sure where they’re originating from, but since the tech support guys on the phone told me they weren’t seeing any packet loss/collisions, I’m assuming it’s the new Comodo Firewall 5 that’s the culprit.

I’ve been using ping plotter pro to check my latency and ping times via tracing. It seems I’ll get intermittent lag spikes anywhere from 2-3 seconds in length. That, and the fact that if I have the firewall enabled, I get reported packet loss from other servers.

Thing that I’ve tried:

  1. Uninstalling AV (avast)
  2. Installing new AV (nod32)
  3. Disabling firewall
  4. Reenabling (will try uninstalling tomorrow)
  5. Updating network drivers
  6. Setting link speed to auto-negotiate
  7. ipconfig /release, ipconfig /renew, netsh winsock reset catalog, netsh -i -i -r -r
  8. Playing with the firewall behavior advanced settings (arp cache, etc).
  9. Disabling ipv6.

Nothing seems to have done the trick.

I’m going to try and uninstall the firewall and then reinstall, but I have a feeling that won’t make the slightest difference. I recently upgraded from version 4 to 5, and used my backup from 4 and imported into 5 no problem. I believe this problem also occurred with version 4, but I can’t be certain. The ISP tells me it’s most likely me, but is there something I’m missing? If uninstalling fails to solve the problem tomorrow, then I’m not sure what I’ll do. I’m hoping this is Comodo related so as to prevent me from reinstalling my entire OS.

Here are some screenshots of my setup:

Global rules:

http://imgur.com/uwhyX.jpg

Network Application Rules:

http://imgur.com/u88Ls.jpg

Firewall Behavior Settings:

http://imgur.com/hIyKz.jpg

Someone please help! :frowning:

Hi wo0kie,

Fastest test would be to enable Windows Firewall and uninstall CIS (Or detach the driver from the adapter*).
This would give you a quick check if it is caused by CIS once you know that we can figure out why it’s doing that.

*To detach the driver open adapter properties and untick “comodo internet security firewall driver” service and reboot, now CIS driver is no longer interfering with your network traffic.

Similar report here:
https://forums.comodo.com/firewall-help-cis/comodo-firewall-causing-very-high-pings-in-windows-7-64bit-t61798.0.html

See, I’m not so sure it’s CIS doing it. I tried uninstalling my firewall today (completely) and my antivirus and the high ping times still occurred (and still are). I made a thread over at DSL reports that has some more information in it if that helps at all. I’ve talked to my ISP and they said they can’t really do anything.

Here’s the line quality test I ran:

Any ideas?

It shows 2 times 2% packet loss from you to the internet at an upstream provider, can’t do much about that there, but it seems to think it’s losing packets send from the internet to you… (20%)

Do you have ADSL and at what speed?
Can you access your routers DSL details and if so can you post a screen shot of the signal strength etc?

wo0kie, if I understood correctly, you have a wireless connection with your ISP. Judging by the data-packets loss rate, it seems that you may have a problem with antenna on your AP.
If it is a classic “stick” antenna usually supplied with the AP in factory package, you should try to lend one with higher gain level and test the connection again. ISP’s use equipment with higher power levels and have high-quality antennas which can pick-up even the worst signals, however, your antenna may be to weak (or you have too much interference on your location), so packet loss occurs.
Don’t buy an antenna! Borrow one, run the tests and see if it worked out for you. Then decide do you really need to buy one. Wireless technology have lots of limitations, and there are numerous factors that can cause packet drops or low signal levels.