Manual Download link for AV Signatures Not Up-To-Date???

I have encountered a problem with the download link in the CIS AV FAQ section …

Where can i download the latest full AV database? « on: November 03, 2009, 07:44:29 AM »

Where can i download the latest full AV database?

As long as Comodo is not providing this on the public website where trying to keep this post up2date.

Will this link work with my download manager?

Yes. It will work with your download manager because it supports resuming. That makes it suited for people on slow connections.

*** WARNING CIS version 3.12 and lower are no longer updated on the AV database ***

*** WARNING THIS DOWNLOAD IS FOR CIS versions 3.13/3.14/4.x and later ONLY !!! ***

Following link points to latest complete bases.cav always

How do i activate this download?


* Save the file on your computer
* Reboot in Safe-Mode
* Open explorer and go to C:\Program files\comodo\comodo internet security\scanners


Type in following in “Start–>Run” and press Enter key:
%ProgramFiles%/comodo/comodo internet security/scanners

* Rename existing bases.cav to bases.old and copy downloaded bases.cav
* Reboot your system in normal mode

Your AV database should be the latest full, and should only need to do an incremental update for the latest updates released after this full.

In short, it appears that the “bases.cav” file yielded by downloading from the link shown does NOT… I repeat, NOT… update the AV signatures to the latest signatures…

I am, by this point, an old hand at dealing with Comodo’s wonky update system, but, despite the combined efforts of myself and two other software engineers, we could not get the file downloaded via said link to update our AV scanner to the current (4260’s ) AV signature numbers…

We’ve dutifully downloaded the file in question three times now, once on another machine at another location … and believe me when I say that on dialup, this is no picnic… and carefully followed the instructions to rename the old bases.cav file to .old and so forth…

Unfortunately, the AV signature number does NOT update using this particular file … We strongly suspect that the file under the current link is flawed in some way…

Previous AV signature update downloads obtained via the CIS AV FAQ’s link have yielded files named “Base_End_User_vxxxx.cav” where the “xxxx” represents the then-current AV signature number. These updates work fine when the prescribed installation method is followed…

The file under the current link does not. This file is named simply “bases.cav”. … ???

Now, I realize that this, in and of itself, means nothing. File names are changed all the time. But how odd that the file we are currently downloading via the CIS program internal updater is NOT designated “bases.cav” , but rather “Base_End_User_v4266.cav”… just like the naming convention used by all our previous manual downloads…

Do you think one of you Worshipful Gurus might take a look at the current file under that manual link and make sure that it’s right… ??

Oh yeah… since you’ll ask…

Windows XP Pro SP3 fully patched
CIS version 4.0.135239
MalwareBytes, SuperAntiSpyware, Spybot S&D, HijackThis, Panda and a couple of others are present but only run as needed

BTW, you get a BIG gold star for finally fixing the program’s internal Virus Database Update Progress Indicator to show an actual meaningful percentage of download progress… But I STILL don’t see a “Pause/Resume Update” button or function anywhere…

I downloaded from the link and got file named = bases.cav

Did a fresh install and copied it in. Yield = Virus database 4266

So yes it checks out,
according to the web page the bases.cav from that link,
should never be more than a couple of days behind the current incremental updates.


It does not claim it will update to the latest available version:

Where can i download the latest full AV database?

I fail to see the problem. The download link gives you the latest available full database. After that it is at most 200 or so kB of incremental ones to update to the latest available database.

Notice that the latest available full database only gets renewed every 2-3 days.

At the time of writing 4266 is the latest available full av database.

It is possible to obtain updater information. This is what it says:

[VersionInfo] MaxAvailVersion=4289 MaxDiff=150 MaxBase=4266 MaxDiffLimit=150

Maxbase: latest full av database
MaxAvailVersion: latest version of available av database

Ok, well, we’re all up to date now, but had to let the CIS internal updater download things it’s way to get there…

As I said above, we downloaded the bases.cav file via that link more than a couple of times… different machines, etc… 88 meg takes quite a while on dialup, but we eventually had the file here to play with… BUT… try as we might, that file would not cause the signature number to go anywhere near 4260

Eric… The issue wasn’t whether or not the file in question would get us to the absolute latest signature # but that replacing the then existing bases.cav with the new file would NOT take. We were able to successfully bring the signature # up to 3516 using an older signature file, but every time we tried to use the newest signature file, the CIS program actually replaced the new file that we had copied in manually with the previous signature file as soon as we ran it. How it was doing this and where it was getting the older file back from, I have no idea… We did do a thorough set of tests and reproduced this behavior using a signature file that had been downloaded on another machine…

Given the weird behavior we were seeing, we guessed, correctly it would seem, that something was corrupted in the CIS installation. The next step was to download and clean install the much touted version 4… ( a pleasant surprise thus far BTW)

Once that was done, we were able to get the signature number from 1 (at install) up to 3516 using the older file, but again that latest signature file wouldn’t take, displaying the same anomalous behavior as with the 3.13 install.

We concluded that the file under the link might be flawed somehow, since we had already downloaded it on different machines with the same results. The natural next step was to ask if someone could verify the file under the link… (Thank you, Bad Frogger ) While we were waiting to hear from someone on your end, we let the internal updater do it’s thing with happy results.

I certainly wasn’t about to download the file under the link again if there was any chance it was flawed.

So, I guess the lesson to be learned out of all this is that the manual download file under the link ought to always have a signature number incorporated into it’s name, as was the case with the previous naming convention of “Base _End_User_vxxxx.cav”

Never would have thought to question that file if it had had that signature number on it. The quality of the download?.. certainly, but the integrity of the file itself, not likely…

Further, as anyone who maintains a backup library will agree, incorporating a version number into an update file name just simplifies things for all concerned. My today current AV signature backup is filed under the name “Base_End_User_v4319.cav” , NOT “bases.cav”

I just tried on Vista with v3.14 and I successfully placed the latest full database 4311 in place. It looks like there was something wrong with the 4260 database you tested with.

Edit: I tried the same thing with v3.14 under XP and v4 under Win 7. They both showed 4311.

Sometimes I found that you had to put the downloaded bases.cav file into the repair folder as well as the scanner one.

I haven’t been able to update my AV database for about 3 or 4 days now, and the manual process doesn’t work as the download link is broken.

hello, you can try this link to download the av database.

scroll down page and you will see DOWNLOAD COMPLETE DATABASE. :wink: