Major problems updating comodo firewall...

Been using comodo firewall for some time (win 7 64), and today I got a ‘install updates’, so I ran it, and it asked to restart. I said restart later, then I had to leave, so I slept the machine, and when I came back I noticed some apps were not launching when I clicked them, so I did a restart. Upon restarting, only 3-4 of my regular on startup apps launched, and ms security essentials was in a ‘red’ not protected state. Comodo never auto launched at all.

Once again, some apps were not launching (cc cleaner for example). I clicked it, but no window showed up. CPU was mostly idle, task manager showed no running apps, but it did show the cccleaner process had started.

Tried another reboot, this time the system hanged on ‘shutting down’, so I had to manually powercycle. Booted into safemode, and saw comodo installed some ‘Priv Dog’ software (the ONLY software that had been installed in the last week). So I uninstalled it, rebooted in normal mode, same problem (ms security essentials fails to turn on completely, comodo never even starts).

The ONLY thing that happened between this afternoon, and yesterday (when everything was working fine) was the comodo update. I was able to run cc cleaner in safemood, and it claimed it fixed some registry errors, but I still have the same strange behavior when running normal mode. I also did a disk scan/auto fix errors on my c:, no luck.

Anyone have any ideas how I can recover from this?

*And when I tried to run system restore from safemode, it said it had no restore points. Odd, I thought windows auto created restore points periodically, but I guess not.

It sounds like something went wrong with the update from CIS. Please try reinstalling CIS following Most Effective Way to Reinstall CIS to Avoid/Fix Problems by my colleague Chiron. It will provide a reliable and clean starting point.

Hrmm I am starting to wonder if uninstalling comodo is going to do the trick. I mean, from safe mode I do a selective startup, and hide all non microsoft services, and disable all on startup items (including comodo). Even then, when I boot, its like my apps just wont launch (trying to launch msconfig just sits there, no window popup, no errors).

How could comodo be causing this behavior, if no part of it is starting on a clean boot? The other thing I am noticing, my comp still hangs forever at ‘shutting down’ (I have to manually powercycle to shut it down).

Perhaps there is a system repair utility I can run off the win7 cd? Or some other repair/diagnostic utility I shoudl run? Or do you think I should still try your steps for removing comodo?

Thanks for the help btw!

Well after running “sfc /scannow”, I was finally able to boot and uninstall comodo. Everything seems to be working fine now. The question is, should I try and reinstall comodo…

Chiron’s guide is based on best practices that were collected to provide a reliable starting point making it worth the try.

In case things would go haywire boot into Safe Mode and run the CIS clean up tool.