Major Problem With The Lastest Update

Alright, this is the sequence of events that have befuddled me since I first turned my PC on today. At approximately 5:30am or there about, I turned on the PC and comodo immediately exclaimed it had an update. This only happens when it is a entire product update, not just a virus database update. So as usual it asked me to reboot my PC after it was done.

After I rebooted, that is where it all went wrong. It seem to have updated just ‘fine’ at first, and I even updated the definitions to make sure everything was working at its best. However, it keeps having a pop up window for windows installer every 3 or so minutes and there is nothing I can do to make it go away. I have tried everything, as I will explain in as much overbearing detail as I possibly can. :slight_smile:

First off, here are the links to my images and a brief description on what happens…

This pops up first…

Then this happens. It gets worse trust me…

I click the “OK” Button and THIS happens…

So then I click the “CANCEL” Button and THIS pops up…

Finally this happens. And the progress bar goes in reverse from right to left…

This is the current version information for my Comodo Security Suite

Now for the technical details.

Windows XP Pro SP3 (x32)
Pentium 4 3.06 GHz Processor
2 GB Ram
300GB HD
VisonTek Radeon 256MB Graphics Card

I am running ALL the latest drivers for absolutely everything installed on my PC. Every program on my PC is the current version and up to date.

First thing I did was a System Restore. That failed to remove the problem. Then I uninstalled Comodo Suite entirely. That didn’t stop it. Then I used the Clean-Up Tool over at this link here:

That seems to have almost gotten rid of it. Then I edited my registry manually by removing every known thing linked to Comodo. Well that got rid of the pop-up. However, I am now unprotected. So I downloaded the latest Comodo off their site.

Which is version: CIS_Setup_3.13.125662.579_XP_Vista_x32.exe

It apparently went ahead and updated itself during its install to the current version. After I rebooted again (for like the 7th time during all this, as I reboot after every step) the pop-up returned. Like a bad movie sequel, it now has a score to settle with me, as it now is on constant pop-up mode every 3 minutes or less. I use a “Junk Remover” program called CCleaner, which also prompts the pop-up every time I run it. I can not find out how to remove this issue, so unless Comodo updates the actual install on their site to a version that doesn’t have this problem… I will have to learn to live with clicking cancel a million times a day.

I have not found any other Free security suite on the internet that is better than comodo. Honestly, I haven’t even found ANY security suite BESIDES comodo. It seems there are stand alone antivirus programs and stand alone firewalls for free, but nothing all-in-one like comodo is. I would hate to ask the next question on a manufacturer’s website… But here goes anyway…

What are the alternatives to comodo? Any other suites I am not aware of? Or name the 2 best programs, the best free antivirus and best free firewall that WILL work with each other and not against each other. I will only use them as a last ditch effort. I am not the only user of my PC, and my roommates might not like having to keep clicking cancel all the time. The previous version of Comodo Internet Security Suite worked flawlessly. No problems, no issues, no hassle. But since it updated this morning, it is ‘technically’ working, but it brought a friend. I haven’t a clue how to stop it or ignore it. So I need options. Unless Comodo is aware of this issue and is fixing it right now, I don’t think I can wait much longer than a week worth of clicking cancel.

If there are no other options or alternatives to comodo, nothing that is ‘as good as’ or ‘better’ or even sub-par lol. Then I will have no choice but to stay with this annoyance. My PC has not changed one bit during the last month, so this is definitely a issue with the latest Comodo update. There is nothing else installed on my PC that has been updated today or yesterday or the day before. Also, as I aforementioned, once I removed all traces of comodo, the problem went away. But that of course leaves me unprotected. We just can’t have that, now can we? :slight_smile:

I hope someone else is actually having this problem, that way something will be done about it. But if I am the only one on the planet earth having this issue… Then I will need to look elsewhere for protection, ironically protection FROM Comodo itself, not BY Comodo. So far it has not damaged my HD or any programs. It just seems to have this annoying pop-up that requests a CD ROM insert to a non-existent item called: Unload.msi – I ran a full deep search of every file on my PC, this is NOT on my PC anywhere. Therefore I have no idea what the heck it wants it for, and why it keeps on harassing me asking for it.

My best guess for what it is… Perhaps it is trying to get rid of past comodo files that are no longer needed with the latest version? It is scheduled to trigger at reboots and other intervals to purge the system of unwanted materials. If this is the sole case, then comodo can update their download to the absolute latest version INCLUDING latest up-to-date virus definitions database… Then I’ll download that copy and reinstall it yet again. That should solve its removal problems it seems to be having.

In any case, I am deeply grateful for whoever decided to read all this mess. Yes I type allot, I just need to express all that is running through my head. I hope I provided enough info, if not, just ask me and I’ll post it immediately. I will be checking this post throughout the day today and tomorrow, and hope for a expedited response and solution fix for this seriously annoying issue. Thank you for your time.


I had a problem with that error 1706 thingie last year. It turned out it was a problem with my copy of windows program installer which had developed a fault. Try downloading the latest version of windows installer and see if it makes a difference.

Good day,

I am sorry to read you are experiencing difficulties when removing and installing versions of comodo internet security. The problem you describe comes up when windows can not find a specific item that is necessary for a program that is using that missing item to function properly.

So in short a program on your pc has been damaged and windows asks you to fix it by finding an item somewhere on the hard disk or a removable media. This kind of problems usually happen when a registry item is removed or changed which causes windows to lose track of items that holds a program together. In my case I get these problems when using a registry cleaner… In your case it seems CIS is changing something in the registry…

Well, how to solve this? there are several manners to solve it:

[1] Do a system restore
[2] Do a registry back-up (almost the same as system restore, only this way your focus is on the registry only)
[3] Uninstall CIS to see what happens.

I read you tried this, with a surprising outcome that without CIS you do not experience any problems… The item that cannot be found is unload.msi

the extension tells us that this file is a microsoft installation file, I think comodo internet security is utilizing a microsoft installation file to install CIS, so maybe something goes wrong when installing CIS. But it also could be that unload.msi is being utilized by an other program that is damaged.

So what you can do is do a google search and see what kind of programs are utilizing unload.msi and see if you have any of these programs on your pc. if so you can try to reinstall those.

Also you can go to, here you can find a list of alternatives for Comodo Internet Security… But it would be a tough decision! :wink:

I wish you good luck!

EDIT: ofcourse try to reinstall windows installer, it could be that windows installer is damaged as bluesjunior suggested.

Well I went to the site he gave to get the windows installer, I DL’ed the latest copy they had available, the 3.1 installer… It said the one on my PC was the latest version and refused to go any further.

I tried a system restore to 2 weeks ago, that didn’t work. I tried uninstalling and reinstalling again. It comes back every single time with Comodo. No other program I’ve removed or put back in brings this pop up back. So comodo is tapping into SOMETHING somewhere on my pc. I also noticed using CCleaner to remove mui references and things that are no longer there, that comodo or something is forcing an old printer to ghost itself on my PC. I remove the references to the HP printer and then soon as I turn on Comodo, they come back to my registry. This is really odd, considering how I removed all mention of and ties to Comodo after my last uninstall. I also did my best to get rid of the HP stuff.

For some reason they seem to be sharing a symbiotic relationship with each other. This printer no longer exists and is not connected to my PC, nor is any visible or invisible files located on my PC. Just some apparently invulnerable registry mentions of it, that is being shared with comodo somehow.

I am still working on this, but I would assume that if comodo updated to the very latest version and offered THAT DL on its DL page, that would fix all my problems. After another uninstall of course. But I am going to figure this thing out one way or the other. I need CIS, it is the best. It has never messed up on me even once until now. I’ve used it soon as Comodo started releasing free copies, so for many years now. Anyway, since only uninstalling and using the clean up tool gets rid of this darn issue, I will have to do that once Comodo finally does update their DL to their product.

I don’t know how to do a registry back-up thingy that you mentioned. I assume that involves the master restore disk and putting just the registry back to all shiny and new. But I would also assume that it would remove all mention of all the stuff I have installed on my PC, thus rendering 98% of my PC useless, as nothing would run and I’d have to reinstall everything again. That is akin to a master restore anyway… I just recently went through the painstakingly arduous task of Reformatting my HD entirely… I might have no choice but to do that again.

I do ask that comodo do hear my pleas, just update the DL on the site to the absolute latest one. Even if I am the only one with this issue, at least that will be a good fix for one loyal user of your product. I know it isn’t much to ask, the program is free anyway and it shouldn’t take more than 10 minutes maximum to do what I am asking. I am not asking for you to reprogram the entire thing from scratch lol. Just need the latest copy up for grabs, that way it SHOULD work on me without damaging whatever it is doing. sigh

If I find out any more information, I will let you guys know. Until then, grabs jack hammer back to work on this annoying issue.


Is there no end to this HP Printer rubbish.
You buy a HP printer and they then own your computer and install unimaginable unwanted rubbish.

HPGS2WNF.EXE process is running again, it wants to share my files with the world wide web again ! ! !

I did nothing to launch it.
I have now killed it.

Every day I look in Windows Task Manager / Processes and most times it is not present,
but sometimes it is.
It was not there earlier today, but now it is running.
I did plug a Flash Drive into a spare USB port a few hours ago.
The HP printer has been powered down for at least two weeks since I last used it,
but it is permanently connected to another USB port.
Could HP be hooked into the system in such a way that a change of state in a USB port will launch a HP process just in case it is needed ?

I suspect whatever HP “ghost” you are seeing, it could re-appear with anything that affects some part of the system - especially any anti-virus behaviour checking software.


Your MSI installer is in a strange state of mind…

Please download this M$ tool:

And use it to uninstall “Unloader” that is causing the trouble… after that see if things work better…

I had the same issue with HP drivers for my scanner, this fixed it.

There’s a long-time bug in the Windows XP Installer. I’ve had it on and off for years, in 5 different computers, with Office 2000. Fusion Fox has it with Comodo, unfortunately because Comodo has to run continuously.

You could try uninstalling Comodo with Revo Uninstaller, then reinstall. Revo cleans out every last registry key and file from an install. I don’t trust the MS Install Cleaner because I don’t trust MS for much of anything. 88)

Then why are you using a Microsoft OS? :wink: