Major Problem After Upgrading to Version 3

Was prompted to upgrade tonight which i did and went for the advanced set up with self learning.
All was well at first but after allowing Steam to work, everything stopped responding. Every application would produce a ‘not a valid win32 application’ dialog. And I mean everything!!! (even control panel)
I tried to restart and it then said it I did not have access rights to do that. (I am admin) powered off into safe mode and then I could run things again Uninstalled Comodo rebooted and all worked again.(phew). I am running XP pro SP2 and little else. Any ideas why I had such a major failure? Ver2 was fine!!

Looks like Steam needs to be totally free to communicate. Here is the page from the Steam website on how a firewall has to be set up if you haven’t already read this:

hope this helps


Thanks for the quick response. Yes I think you are on the right track. I am just surprised it rendered the whole PC unusable!! I will try a reinstall. If I go for a basic setup this time will that give full protection to anything trying to talk out? (my main concern) .