Major GUI bug v3.0.22.349 (Vista x64) [FIXED]

Just done an update to the new build, using vista x64.
GUI is all messed up , got no close,minimize,maximize buttons at all.
Also in network security policy - scroll bar does not move.
Screenshot attatched.

[attachment deleted by admin]

I can confirm the first posters problem.

On my Windows Vista Ultimate x64 (with sp1 and all important updates) machine, I upgraded from to using the “Check for Updates” button in the Miscellaneous tab. After reboot, the GUI was missing the standard windows “minimise, maximise, close” buttons in the top right corner and list boxes didn’t work. I then used the firewall “Diagnostics” button to check for problems, and it took a long time and said none was found. A reboot after this and all my firewall rules disappeared.

I also uninstalled Comodo firewall and reinstalled it from scratch with the same symptoms/problems.

Hence, I uninstalled and am now currently running with no problems.

The only other security application I have running is Eset’s NOD32 Antivirus (not firewall) 3.0.642.0.
My Network Defense is set to “Train with Safe Mode”. My Proactive Defense is set to “Clean PC Mode”.
I didn’t modifiy any advanced setting. However, I am running several VMware virtual machines, which have their own two subnets.
This occurs in both my Administrator account and Standard User account.
The screenshot posted above highlights the same problems I have.
Can this bug please be fixed promptly, as Comodo Firewall is very good. :slight_smile:

In addition, a lot of Vista x64’s standard system programs aren’t recognised by Comodo firewall. For example, “wmplayer” creates a “catroot” directory under “c:\windows…” and Comodo thinks it’s suspicious. Is it possible for Comodo to recognise most, if not all, of Vista x64’s system programs?

Thanking you in anticipation.


Exactly the same problem on my Vista x64 SP1 machine , GUI slightly corrupted, the max, min and close button are there just invisible :THNK

Previous build was perfect :BNC

Another one with GUI problems in Vista 64 SP1…

Yep … :THNK

I have the same problem…

I can confirm this as well. Come on guys if it ain’t broke don’t fix it! Previous build worked fine, and updates are supposed to correct bugs not create them. (B) But we Need 120 Percent Damnit!

I have the same problem,too.After updated from to automatically. The appearance got wrong.
My OS is vista ultimate x64 sp1, I hope this bug can be fixed quickly.
I’m a user from China,and I’ve used comodo for a long time (CNY).

Well I switched to a beta version that I found in the beta section. Version 64 bit. While I didn’t find a link to it directly I right clicked the 32 bit version hit copy link location and then pasted it into the address bar and changed x86 to x64 and it worked. Threatcast seems to be pretty cool, and I wonder why Comodo didn’t put it in Anyway there is no GUI bugs in this version, and while it is beta it does add Threatcast… Which should have been added to the release.

Ok screw it I give up. Can you tell me when a new release is planned that is going to fix this? The beta that I installed isn’t saving any rules at all between reboots and after S3 sleep locks my damn system… So I’ve had enough, and will have to go back quite a ways to a few month old version.

Same issue here on Vista Home premium x64.

Using Nvidia 174.74 driver and have tried both the update and fresh install route.

Ok what is the status on this one? Is it just us 64 bit users?

Hi guys,

We are looking into the issue.

Thanks for the feedback,


Addition on this x64 GUI issue:
noticed that scrollbars don’t work on any Firewall or Defence+ screen. When grabbing scrollbar with mouse it correctly changes to highlight color (blue) and then just freezes. After that there’s no response on either arrowbuttons or scrollbar itself.

Yep, so it seems. As so far all 32-bit users have commented this like we were mentally challenged. Or caused this issue ourselves. Or haven’t read the manual.

Great news Egemen, thanks.

I am having the same problem, I posted in another thread because I didn’t realize this thread existed.!

[attachment deleted by admin]

It’s only a 64bit issue guys :frowning:


Any word on a quick fix…? We want it and We want it NOW…! No I’m just teasing of course. (R)

well at least the firewall is working just fine as previous version…
but i still waiting for the quick fix though :slight_smile:

in “Network Security Policy” vertical scrollbar does’t work

Are you using Vista x64 or some other OS? What version of CFP are you using?