Macrium Reflect crashes at startup [InValid]

Macrium Reflect crashes at startup if Defense+ driver (cmdguard.sys) is active.

Steps to Reproduce:

  1. install Comodo Internet Security (CIS): without Antivirus, maximum proactive defense, without Safesurf; restart system; set Defense+ of CIS to “disabled”;
  2. install Macrium Reflect free version;
  3. launch Reflect’s shortcut.

Reflect crashes, producing memory dump.

System info:
Windows XP SP2 32 bit, Reflect free version ? (cannot tell exact number at the moment - latest available from their site), Comodo Internet Security v3.8.65951.477 x32.

Additional Information:
If cmdguard.sys is disabled (e.g. under CIS settings: defense+/advanced/deactivate… permanently…) and computer is restarted then Reflect doesn’t crash. If re-enabled - Reflect crashes.

COMODO Internet Security v 3.10.102363.531 → same bug

I run reflect free with CIS 3.10…531 and it runs OK for me. Initially, when Reflect starts it wants to get all the way down to your systems toes to do its job. Maybe you have a rule blocking an action that Reflect needs to run.

Try placing the firewall and D+ in Training Mode -carefull to be OFF the internet - and the try to open reflect. I actually found this to be the easiet for this program as D+ alerts many times as Reflect reaches into the system very deeply by design. After the program comes up, close it and then go back to your original settings.

Once this is done, then you should be able to start the program without any popups in firewall or D+. Hope this direction helps.


nope, it doesn’t matter to what mode i put D+ (tried “Training” and “disabled”) - upon start reflect.exe crashes producing crash dump (which i already sent to Macrium long ago). Only disabling Comodo sandbox driver (cmdguard.sys) will let me start Reflect on my system.

–thanks for trying to help, Mike

Bug is fixed as of Reflect free v4.2 build #2076.

It seems it was not CF’s bug, my apologies.