LPS desktop window won't take my LPS ID.

HI folks. RE: version 2.0.108379.1.

Things are pretty quirky, but think this is the bottom line. When I get the window open to enter my comodo ID (got in email), it is not recognized or just doesn’t take. As a result, I solely get a “not connect to server… …try again.” window that then opens. I try the correct ID number over and over, same result. Have tried to email commodo at the prescribed email address but no response. LPS chat can’t seem to help.

Anybody here know whats going on?

Thanks in advance, Diligent.

Are you still having issues in connecting to the LPS Server ?

Yes, as of SAT or SUN, the ID number just does not work to open LPS. Going to try contacting Comod main offices, about the lack of a return email. I have the contact info (in general).

Thanks for inquiring. You know anything about how this works or is supposed to work, and why it is not working with the ID I was given?

Appreciated, Diligent

Can you provide me the exact mail address to which you have mailed about this issue ?

Yes. It is an email address I was given by one chat person, which is the same one that is referenced in the popup window that appears after my attempted access to LivePCSupport fails.

email address: cisquestions@comodo.com
email date: Wednesday, August 26, 2009 7:53 PM
Sender: Diligent Inquirer

Thank you very much for your efforts. Much appreciated. Diligent.