Low ID Emule -> Comodo Firewall problem

Hello. I have a problem with the Comodo Firewall. I have added the emule in the list of allowed applications of the Firewall. However, when I run the program icon of the donkey has a band in the eyes, which means I have ID low and firewall closed. When I disable the Comodo Firewall I have ID high and firewall open. I’m using the latest version of Comodo Internet Security. What is the problem? Why Comodo Firewall does not perform well his work with emule?

Depending on which CIS configuration you’re using, you may need to add one or more Global firewall rules to allow TCP or UDP inbound to your emule ports. If you can check to see if you have a global rule that Blocks IP in (usually it’s the last rule in the list) you’ll need to make the aforementioned exceptions.

I have the configuration that comes by default. In Global rule appears marked the last option “Block IP…”. What should I do to allow TCP and UDP at the entrance of the port of the emule? I do not understand well what should I do. Please help me.

Ypu don’t mention which version of CIS you’re using, however, this only make s difference in where to find the area you need. Basically, you’ll create one or more Global firewall rules. The first thing you need to know are the ports you use for emile. To find this information:

  1. Open emule
  2. Go to Options/Connection
  3. Make a note of the Client Ports (TCP and UDP)

Create the rules in CIS:

Under CIS 5.x - Navigate to: Firewall\Network Security Policy\Global Rules
Under CIS 6.x -Navigate to: Tasks\Firewall Tasks\Open Advanced settings\Global Rules

If the port numbers are different, you can either create a Port set:

V5 - Port Sets
V6 - Port Sets

The use the port set in a single rule or you can create two separate rules, one for TCP and the other for UDP.

In Global rules create the following:

Action - Allow
Protocol - TCP
Direction - In
Source Address - ANY
Destination Address - ANY
Source Port - ANY or use a port range 1024-65535
Destination Port - Your emule TCP port

Action - Allow
Protocol - UDP
Direction - In
Source Address - ANY
Destination Address - ANY
Source Port - ANY or use a port range 1024-65535
Destination Port - Your emule UDP port

If you want a single rule, use TCP or UDP in the Protocol field and your port set in the Destination port field.

[attachment deleted by admin]

Hello. I have Version 6 of Comodo Internet Security. I tried to do what you say but it does not work. I add some pictures for you to tell me if I have something misconfigured. I have found a somewhat radical solution, if I deactivate Comodo Firewall yes I have high ID and firewall open but not know if that is recommendable. Thanks.

[attachment deleted by admin]

The problem you have is that you’ve created a port range, however, whet you have is two individual ports.

Action - Allow
Protocol - TCP
Direction - In
Source Address - ANY
Destination Address - ANY
Source Port - ANY or use a port range 1024-65535
Destination Port - 55085

Action - Allow
Protocol - UDP
Direction - In
Source Address - ANY
Destination Address - ANY
Source Port - ANY or use a port range 1024-65535
Destination Port - 51985

For single rule:

Action - Allow
Protocol - TCP or UDP
Direction - In
Source Address - ANY
Destination Address - ANY
Source Port - ANY or use a port range 1024-65535
Destination Port - Emule port set

You might find things easier if you use individual rules.

[attachment deleted by admin]

I did what you said. Still not working ???

[attachment deleted by admin]

As mentioned in my first post, you need to place the rules above the block rule.

[attachment deleted by admin]

Thank you so much. Everything works fine now :slight_smile:

You’re welcome :slight_smile: