Lost Internet Connection,

I installed Comodo about a week ago in place of ZoneAlarm. After a couple of days, I noticed I could not receive mail on Windows Mail. I was having some problems accessing web pages so decided to install Comodo though Control Panel. I removed the Anti Virus, the firewall and Webcrawler. Afterwards, I could not connect to the Internet. On this board, it was suggested to reinstall Comodo and uninstall it using Revo but there was still no Internet connection. The computer is running 32 bit Vista Home Premium connected to ADSL through a Belkin G Adapter and a Linksys wireless router. No networks show up although previous to this install and uninstall, my secure wireless network was showing up as well as three others in the neighborhood. I have been on the phone with tech support for my ISP for the past two hours. We tried a system restore but not only have the system restore points been wiped out, I am no longer able to set a system restore point. It gives an authenticiation error message. I have used restore points in the past so I know they were there previously. The only answer the ISP can give me is to do a complete wipe of the system and reinstall Windows. I really don’t want to do that if at all possible. Can someone give me some help before I take such a drastic measure?

BTW, I am on my laptop, and the wireless connection is working just fine on it but it has AVG iand Zonealarm nstead of Comodo. I was planning to put Comodo on this machine but need to get the other computer up and running before I try it again. Any help will be greatly appreciated. Thanks!


Have you tried turning off and then back on the wireless on your laptop and turned off and back on your wireless network?

It sounds to me as though your wireless connection might be disabled.

Right Click “My Computer” on your desktop and click “Properties” Click “Hardware”, Click “Device Manager” and scroll down to your wireless card.

Right click it and click “Enable” if it is not enabled.


Yes, I have disconnected the wireless router and reconnected it. The laptop is fine. It is a desktop that I am having trouble with and the wireless adapter shows that it is enabled.

In my previous post, I said that I had installed it through Control Panel and it should have read that I UNinstalled it through Control Panel.

There are only a few other things I can suggest at the moment as it’s not my area of expertise. Check your Firewall logs for any blocked alerts.Also check that Windows Firewall is Disabled. Usually the installation of CIS doesn’t disable Windows Firewall and sometimes can cause connection issues.


After another hour on the phone last night with Belkin tech support, I was told once again that Comodo has messed up Vista so badly that I will need to wipe everything and go back to the factory settings. Of course, this isn’t what I want to hear so I am hoping that someone here on the boards can give me something else to try.

Has anyone else successfully installed Comodo on a Vista machine?

I am running CIS 3.8.xxx.477 on a Vista Ultimate x64 machine with no issues after installation.
CIS will NOT remove any System Restore Points.

First, uninstall CIS with Total Uninstall. (Note - do not reboot when the uninstaller asks, let TU clean up any remaining traces of CIS).
Then, disable any and all other AV scanners on your system, as they may cause a corrupt or faulty installation.
Reboot, log into your Admin account (make sure your network is functioning correctly) and do a clean install of CIS.
After installation, reboot as the installer requests, and log in. If you desire to use another AV and you elected to include CIS’ AV in the installation, please make sure you disable CIS’ AV. You should now be able to re-activate your other AV scanners.

I hope this helps you.

Hey all!

first off I love the comodo products, I am currently using the mjority of them with no regrets BUT I have XP SP3 and after I installed CIS I now have a Winsoc error which has made internet connection on my desktop impossible. I also have a lap top which is using my connection just fine but my poor desktop cannot.

Download and run Winsockfix.exe

Thanks I’ll give it a shot