Losing Internet Connection

Hi
Just switched to Comodo after years with ZA (fresh install so no ZA dregs)
Been running Comodo AntiVirus_2.0.17.58_Beta and Comodo Firewall_3.0.25.378_XP_Vista_x32 for weeks with no problems.
Received message to upgrade so installed CIS_Setup_3.5.54375.427_XP_Vista_x32 last night.

When first installed on XP (32) I receive a message to name my Network.
I can connect to the internet.
However, when I restart I receive another message to name another Network (cannot be named the same), but whether named or not my internet shows a no connectivity error.
I then cannot connect to the internet again until I uninstall Comodo completely.

All PC connections wired Ethernet, so not wireless problem.
I have 4 partitions (XP32 x 2, XP64, Vista 64)
All other OS’s connect no problem (not using COMODO)
While the internet shows no connection on main PC I also have another PC XP32 that connects using same router (wired), so not a router problem.

The only possible other Network found could be the Wii using wireless connection.
Any ideas?

Have you checked CIS firewall log under ‘‘Firewall → Common Tasks → Firewall events’’? Was there any blocked entries?

Which OS are you using? If you use Vista, it may be a bug. I had a similar problem. After I installed a Hotfix the problem seems to be solved.

OS is XP32
Blocked entries are:
C:\WINDOWS\system32\svchost.exe

So I did another search on these forums with this info and found this:

Here's the problem. It seems that svchost.exe has been classifed in CFP as being a "web browser". Svchost.exe is a great many things, but it isn't a web browser. It needs to have it's CFP rule setting changed to be"outgoing only"

To do that, go to the Firewall/Advanced/Network Security/Application Rules tab, and then look down that list to find “C:\WINDOWS\system32\svchost.exe”.

Click on that line to edit. When the rule window opens, choose the button that says to “use a predefined policy”, and select “outgoing only” from the pulldown list (was “Trusted Application”). Then click Apply all the way out.


Tried this and internet connection is no longer blocked :BNC
Not sure if this will be fixed in future releases but found a lot of peeps having a similar problem.
Thanks for the help.