Losing Internet Connection Overnight [Resolved]

If I leave my internet connection open overnight, in the morning I have to reboot to go online again. Or if I leave it on and go to work, I lose connection and have to reboot.

This has been a problem for several weeks. I thought it had to do with the Office Installer that kept trying to load, but I fixed that issue (I uninstalled it!).

Notably, I downloaded CA Antivirus (and uninstalled after running a check). I also downloaded System Mechanic (and uninstalled). I’m guessing that a setting may have changed during this process.

I can’t use System Restore. After Toggie helped me on another problem (:LOV), I choose to not use SR since it is a hiding place for viruses.

If necessary I can take screenshots of my HiJack This, TCPView, and Process Explorer. I just have to do that after I get off work. ??? ???

How are you connecting to the internet? If using a router it may be worth checking the settings, my old router used to disconnect after a period of inactivity and I had to re-boot to connect again.

Maybe there is some setting changed on your network adaptor:

Link Down Power Saving = Disable Saves power by disabling the NIC when it has no link.
Link Speed/Duplex Mode = Auto Negotiation auto negotiates the link speed (10base/100base/1000base full/half duplex). Duplexing is “talking” and “listening” at the same time…if your card is full-duplex, it can send and receive at the same time.
Network Address = Not Available describes how you got your network addy (assigned/dhcp/etc)
Optimal Performance = Disable this depends on the OS and the Card. Many times what this means is your card can adjust the size of the transfer window and MTU to improve performance on various lines of various states.
Receive Buffer Size = 64K bytes how much data your card can buffer before it has to process some or return a time-out.
WakeUp on ARP/PING = Enable allows your card to wake up when it’s hit with a ping (ICMP) or ARP request (something is looking for your machine).
WakeUp on Link Change = Disable allows your machine to wake up on link state changes (line goes up or down).
WakeUp using APM Mode = Disable Probably advanced power management - allowing the machine to wake on a machine with APM settings (sleep after so many minutes/whatever)

Thanks for the quick reply!! (R)

I will check those when I get home. From memory it is a Westell 6100 (?), BellSouth Ultra DSL, CAT2 line, Linksys Ethernet card shows “limited or no connectivity”, Network card shows OK; XPsp2, Comodo Firewall, Avast Antivirus, PC Tools anti-spyware. (not bad from memory huh).

I’ve in the past had automatic updates turned OFF. This seemed to start after I got the message from the PC Tools Spyware that a newer version was available. I just got it about 2 months ago, so I am not going to pay for a newer version. I’ll find another one first.

Again, thanks for the quick reply and I will check the settings after I get home from work. :■■■■

The most likely scenario to me is that you’re losing your IP address due to DHCP issues. Svchost.exe will regularly contact your DHCP server to let it know you’re still alive. If it’s unable to do so automatically, your connection may be lost.

Check your logs for blocked entries; most likely outbound. If it’s related to DHCP, look for ports 67 & 68. Check for blocks on svchost.exe as well (both in the logs and Application Monitor).





These are the two closest to the top. As the list goes down, there’s more of the same. The svchost.exe sounds plausible, I do remember a week or so ago having a program try to use it to connect to the internet. One of the two I removed.

At first I could just reset (unplug) the modem, now I have to restart.

Okay, so AppMon is blocking svchost.exe. The ports 67 and 68 on those alerts say it all… your dhcp lease renewal is being blocked because svchost cannot connect to update/renew the lease. The lease expires, and the connection goes down.

Open AppMon, and Remove any and all entries for svchost.exe.

Then go to Security/Tasks/Scan for Known Applications. When it’s finished, instead of restarting the FW, reboot the computer. If you see any alerts for svchost.exe, please Allow w/Remember checked.

Then, provided that Network Monitor is not blocking that UDP access, you should be good to go; try it out and see how that works for you.


You lost me on the “lease renewal” part, but I did as you suggested. I’ll check back tomorrow (maybe evening) and let you know how it goes. I do remember denying something that was trying to use svchost to connect to the internet. Usually I deny, find out what it is if I don’t already know, and then go back and change it if needed. Guess I forgot!!

Thanks SO much for your help. Everytime I have a problem, someone always has the right answer. (R)

Sorry for the confusion… DHCP is:

The Dynamic Host Configuration Protocol (DHCP) is a set of rules used by communications devices such as a computer, router or network adapter to allow the device to request and obtain an IP address from a server which has a list of addresses available for assignment.

In simple terms, when you go online, your computer asks your ISP for an IP address. Your ISP “lends” you an address for a given period of time (usually 12 or 24 hours); this is called the DHCP Lease. Whenever the lease is set to expire, your computer has to ask the ISP to renew it (just like for an apartment or something). Windows uses svchost.exe to control this process; if svchost is being blocked, then the lease can’t be renewed, and your internet connection is lost. There’s probably a popup happening for svchost, but you’re not there to allow it.

The most recent Windows updates have wreaked havoc on the system processes; they seem to have changed everything, and thrown CFP users for a loop because of popups they’ve never seen before.

Hope this takes care of it for you; let us know how it goes.


I thought it may mean something like that. So I left it up overnight and while I was at work today, and when I came home all was fine. I’ll just keep an eye on it for awhile. (:KWL)

I’ve been using CPF since maybe April and soon Toggie helped me with open ports. But I never used any of the features like “scan for known applications”. It’s all I can keep up with helping people in the MySpace forum!!

But THANKS so very much!!! You seemed to hit the nail straight on.

Is COMODO married? LMAO (L)

Great! I’ll go ahead and mark the topic as Resolved then. If the problem crops back up, just PM a Moderator (please include a link back here) and we’ll reopen it!



(M) (:WIN)

Little Mac, you should get an award. Running 24/7 since your directions to fix and NO problems!!

You guys are the best. Mark it “Resolved by a Pro” (:CLP)

Tnx for the feedback; I’m glad that’s working well. Tnx for the compliments as well.