Losing folder structure when excluding sub-folder

I have been trying out Comodo Backup (v4.3.7.17) and have a problem which I can’t sort out! I am using ‘Simple copy’ mode so that I can see what is happening on the destination drive.

If I backup all of the ‘My Documents’ folder then there is no problem - everything is reproduced on the backup drive exactly as it appears on my laptop hard drive.

Let’s say ‘My Documents’ has the following folder structure -

Folder A with sub-folders A1, A2, and A3
Folder B
Folder C

If I exclude sub-folder A3 from the backup then the copy on the backup drive appears as -

Sub-folder A1, Sub folder A2, Folder B, and Folder C all at the same level.

There is no longer any reference to Folder A and I have lost the structure that shows A1 and A2 as sub-folders of A.

This is driving me nuts! Can anyone help please?

I had the same problem, and I think I’ve figured out the cause. Whenever you deselect a folder within some top-level folder, the top-level folder is also deselected, and all its children become new top-level folders. These top-level folders are all grouped on the same level, which is why you lose the structure. You can clearly see the problem if you switch between the “more options” and “fewer options” before and after deselecting the folder.

To work around this bug, you can add an “exclusion” filter in the “Filters” section of the last step of backup settings. Enter the folder (or folders) you want to exclude like this:

Note that the program only allows you to enter a limited number of characters. If you run into the limit, you can press the “export to script” button and edit the script file to add all the characters.

To the developers of Comodo Backup:
Please improve the following features in the program:

  1. Enhance the way source items are selected so that folder hierarchies are preserved even when subitems are deselected.
  2. Remove (or greatly expand) the limit on the number of characters entered for Filters.


Thanks for the reply dripdrop. You have summed up the problem precisely. I have tried to explain the issue on two occasions during an on-line chat with Comodo support personnel and they just cannot (or will not) understand the problem. Apparently it is my understanding of how Comodo Backup works that is at fault!!!

I had tried using a filter to exclude the folders that I didn’t want in the backup but was frustrated by the limitation of the number of characters permitted. I didn’t know about the ‘export to script’ option and the ability to edit the script file. I will give this a try.

The early version of Comodo Backup that I have (v1.0.3.0) doesn’t have any of the limitations of this current upgrade. Maybe I’ll just stick with that. So much for progress!