Loopback rule problem

I’ve had problem with running thunderbird from an encrypted volume from some time now (the volume is always mounted to the same path). Even if i give thunderbird a “tcp allow all rule” i still get prompted by the firewall for each loopback request. I’ve already tried this:

Allow TCP Out From IP Any To IP Any Where source Port is Any and Destination Port Is Any

and previously i had this rule:

Allow TCP Out From IP Any To Where source Port is Any and Destination Port Is Any

but as you can see from the screenshot Comodo keeps prompting me for each loopback request and so i keep creating a new rule each time i get a prompt. It as if the firewall ignores any existing rules when there is a loopback request.

The problem has persisted over re-images, re-installs, numerous versions, etc. I’m currently using version 3.10.102194.53.

I don’t have this loopback problem with any other application.

[attachment deleted by admin]

Try using the standard email profile for Thunderbird.

[attachment deleted by admin]

The reason you are being prompted each time is because the port selection is random. As Eric suggested, use the default tb rule or alternatively, just set the destination port to ANY on one rule and delete the rest.

i understand the destination port is random. the question is why would i get a prompt when i’ve already set the destination address and port to “ANY”?

Look at my screenshot ive attached to this thread, i have already have this rule:
Allow TCP Out From IP Any To IP Any Where source Port is Any and Destination Port Is Any

Now, look at the rules just above it. Those rules above it are created as i am getting loopback request prompts. I shouldn’t be getting those prompts when i have TCP allow all rule.

This seems to be a bug regardless of the fact that the email client profile rule works as Eric noted.

It’s possible there is a problem with your configuration. I’ve just tried this with my tb client and setting the rules manually do work, as does the predefined rule.

Ive just done some playing around with ThunderbirdPortable and it seems that you need the loopback rule in place and cant just have the TCP Out Any/Any/Any rule, you must also have a loopback rule.

It does not seem to be the case with Thunderbird(non-portable) you can have just the TCP rule and it works.

Must be the way CIS handles portable apps which is causing this, i even made a rule for the loopback zone i.e. Allow TCP out from IP Any to IP where source port in Any and destination port is Any, and was still prompted by a loopback alert pop-up.

I reckon this is a portable app thing!


Hi Matty, I’m not sure I get this.

First, I don’t like apps that come from portableapps.com, assuming that’s where you got yours? For me a portable application, is one that needs no installation.

Second, I downloaded tb from portableapps and unpacked it using 7-zip. apart from some crud that portableapps add, the extracted folder is exactly the same as an extracted copy of tb from Mozilla.

Personally I don’t use the installer for firefox or tb, I use nightly zip builds, read portable. I also don’t install into the default location.

Either way, creating rules manually or using the default email rule works.

Downloaded ThunderbirdPortable from Majorgeeks and placed it on a USB stick. Ran it the first time and received a few pop-ups(like a) which i answered then created the rule b.
Now i removed the rule for loopback requests (c) and ran from the USB stick again whereby i received 2 loopback alerts (d)

I`m not sure if it matters but i chose the installation folder as a new folder on the USB stick.

Okey i`ve unpluged the USB stick and my application rules for Thunderbird Portable are manually created (see aa and ab) ANY for all.
Now i re-run ThunderbirdPortable from USB and get 2 pop-ups for (ac+ad)


[attachment deleted by admin]

This would all seem to be usb drive related. I’ll have to try that. It’s interesting…

i just got a prompt that an update (v3.13.119746.572) was available and of course i installed it and it appears this bug has finally been fixed. i removed the 100 or so loopback rules that have accumulated over the last several months and everything is working as it should.

well done guys!