LogMeIn Help

Hello all - and thanks for such a great and helpful forum. There was another post about logmein that was full of good info, but I wasn’t able to quite find a solution to my specific problem…so here is mine:

If I launch LogMeIn for the first time…CFW prompts me to accept/deny traffic from the following .exe’s:
LogMeIn.exe
LogMeInSystray.exe
raabout.exe
Which i accept…the problem is that LogMeIn in my system tray is reporting that it is “Enabled - but offline”, and I can’t seem to get it working.

Observations / things I have already tried:

  1. If disable LogMeIn, then change CFW’s Computer Security Level to “Allow All”, then enable logmein again, all works fine, so i’m thinking it’s definitely a firewall setting
  2. After reading the other LogMeIn related post, I tried going into application monitor and selecting the “Allow all activities” (Allow invisible…/Skip security checks… checked) for all of the 3 EXE files i referenced above - i thought this would fix it, but it didn’t
  3. (I think this one actually shows me what my problem is…only i’m not sure how to fix it) First I again disabled LogMeIn… I then went into CFW’s “Activity” → “Logs” screen and completely cleared it…Then I re-enabled LogMeIn and watched for changes - sure enough i got a log entry the second i clicked to enable logmein…i repeated this behavior 3-4 times to ensure it wasn’t a fluke, and got the same results every time - here is the log entry (exported to HTML) - it references svchost.exe trying to connect - I think svchost is a windows executable that can be called from many different applications…I don’t want to globally enable svchost necessarily - i just want to allow it when LogmeIn is trying to utilize it…anyway - here’s the log entry:

Date/Time :2007-07-14 11:15:01
Severity :Medium
Reporter :Application Monitor
Description: Application Access Denied (svchost.exe:68.xxx.xxx.xx: :dns(53))
Application: C:\WINDOWS\system32\svchost.exe
Parent: C:\WINDOWS\system32\services.exe
Protocol: UDP Out
Destination: 68.xxx.xxx.xx::dns(53)

Oh and one other observation that seems relevant…Starting from a fresh boot of my system: LogMeIn will report itself as being Enabled - but OFFLine…If i drop the CFW (drop Computer security level slider to “Allow All”) and then re-enable logmein, it connects successfully…it seems as though i can then turn CFW back ON again, and the LogMeIn connectivity remains…at least until the next boot…

ok, so after re-reading my own original post, i decided to go into the main application monitor and search out svchost.exe…i found it, and sure enough it was blocked…I’m not sure why. My assumption would be that at some point CFW notified me that svchost.exe was trying to establish an outgoing connection, but i’m guessing that maybe it also referenced for me the specific application that was trying to use svchost to connect…and maybe i didn’t want that particular application connecting, so i denied it…again - i’m not 100% sure - just taking a guess…

in any case, i right-clicked and completely removed svchost.exe from the application monitor list…i again tried disabling and re-enabling logmein, and voila - this time it worked - however, i did not get any alerts from CFW that svchost was trying to connect, and no errors/messages were generated in the Logs section of CFW…so I guess it’s working, but i would still very much appreciate if someone could shed a little more light on exactly what was happening with my situation…i don’t really feel comfortable when i “fix” something basically by trial and error, without fully understanding the implications of my changes…I don’t want just any application being able to access the net via svchost.exe, just because i allowed it for LogMeIn