Log is sometimes Incomplete

Hi,

i use cpf 3.0.22.349

sometimes my log is incomplete, sometimes not.

→ see attachment:

I allowd this application to go out, but in the log i can only see the “asked” action.

[attachment deleted by admin]

Have you tried to click on MORE.

“MORE” shows exactly the same!

[attachment deleted by admin]

Hi erty,

From what i`ve seen the firewall logs each action for each IP address(if configured that way).In the example you have answered the pop up which was ask so this is now allowed but the action was logged.When you are asked but block it you will get a block entry,but when you are asked and allow you get an asked entry.
Why in this case do you think the log is incomplete?

Matty

ps try putting a log on Allow(and log) IP out to ANY/ANY/ANY in Global Rules you will see what i mean

for some applications logs only “asked” → for example “The Bat” see attachment
and for some applications logs “asked” and “alowed” → for example “Tune Up” see attachment

both application use the same rule.

Thanks

[attachment deleted by admin]

Hi erty,

After doing some testing it seems that an application that connects using your browser as the bat does i think(sorry ive not used it) will only give you the ask log but an application thats makes its own connection gives the ask log and the allow log.Not 100% sure on this but i`ve tried a few and got similar results to you.

Matty

Hi Matty,

all these applications makes their own connection.

Ultraedit and windows washer have same behavior.

perhaps a bug?

edit:

Ha!!!

today my log seems to be o.k.
i changed nothing…

→ see attachment

[attachment deleted by admin]

is it a bug?