Lockhunter and 4.1 sandbox [Renamed]

Cannot install lockhunter x 64, because Sandbox pops up continiously, no matter what i answer to this question on the picture.

My system and security setup here-> https://forums.comodo.com/bug-report-cis/cis-41-cfpexe-still-freezes-not-fixed-t57062.0.html

[attachment deleted by admin]

I’ve installed it without problems. The only alert was that in attachment.
After that I put it in My Own Safe Files and CIS is silent like a grave. :smiley:

Seven x64, Proactive, FW and D+ Safe Mode, Sandbox enabled, no AV.

[attachment deleted by admin]

And what is this typo:
Publisher…their application?I think that the publisher is singular.

Yes it looks possible that you might have said no to the latest version of the elevated privs alert (‘unlimited access’)?

Did you maybe? If so try re-installing.

Else try manually adding to My Safe Files

If no luck please append your D+ logs, so we can work out what is going on.

Best wishes

Mouse

Reinstalled CIS and imported my old config(with SB disabled).Now CIS works fine, but…

Is this still happening with sandbox enabled in 4.1.xxx.920?

If so please give further details as requested here.

And attach a screenshot of your Defense plus logs.

Best wishes

Mouse

Thanks I appreciate it

Mouse

So…the installation went good. :-TU When i tried to start lockhunter, D+ popped up with question:

http://img716.imageshack.us/img716/6513/fixw.th.png

I said ‘‘allow’’, but every time i tried to start it, D+ asked me the same.Tried to threat it like trusted application, but didn’t work. Then i disabled these two options in the SB settings:

http://img809.imageshack.us/img809/1684/hmm2.th.png

and now everything looks fine.:slight_smile:

Up:
If i uncheck just the second option ‘‘automaticallly detect installers/updaters…’’ it still works fine.Asked just once to put it in the SB or not(said no) :-TU
If the option is enabled, D+ pops up again.That’s it.:slight_smile:

I’m not clear why you would want to run the setup program more than once. THis alert is supposed to pop-up every time you run a setup program.

Obviously I’m missing something!

Best wishes

Mouse

My mistake.It was the wrong screenshot.Here it is:

This alert appear every time i launch lockhunter.

edit:I tried to put lockhunter.exe manually in ‘‘my own safe files’’ and this time it worked.No alerts anymore with all options of the SB enabled. :-TU

edit2:The only thing i wonder, is why i need to put it manually in my own safe files ?

[attachment deleted by admin]

So, the truth is, that i deleted the ‘‘my trusted application’’ rule for lockhunter.exe, then enabled the sandbox, then lockhunter.exe went to ‘‘my own safe files’’ and that’s it.

OK what seems to be happening here is that Lockhunter is one of the rare executables that asks to run with admin privileges. Normally its only installers that need to run in this mode, and you only run those infrequently, so there is no remember option on this alert. When you say ‘allow’ it doesn’t put it in my safe files - it just allows it for that time only.

You’ve now put it in ‘My Safe Files’ manually, but candidly I’m not sure why it has not still popped up the '‘unlimited access’ alert, since ‘my safe files’ did not used to give it admin privs. Maybe its just silently denying the request, or maybe this is new 4.1 behaviour, and its silently granting it. If you get any unreliability problems with this program I would define it as an installer/updater in the computer policy - this grants it admin privs AND ensures that it remembers.

Best wishes

Mouse