Locked out of windows since installing comodo

Since installing the latest version of comodo I have lost all user rights in windows, I cannot start any applications and when I try to close windows down I just get a dialogue box that says that I do not have the neccessary permissions to shut down.

Any help would be greatly appreciated.

Hi & welcome.

I moved your post to the v3 section, since I believe this is a Comodo Firewall Pro 3.0 issue? If not, please give us more details so we can get you topic in the proper section.

If I understand correctly I recognize this bug. I’ve experienced it myself (not on my own machine though). The fast solution would be to restart your computer in safe mode and uninstall CFP. However there may be a workaround for this, I have a vague memory of something related to Image Execution Control.

I hope someone can take over from here and give you more tips of how to solve this.

LA

Possibly you responded to a perhaps confusing popup and blocked explorer.exe, which launches applications. Uninstalling and reinstalling is usually required to fix the problem.

This usually happens by clicking block instead of allow. Look under the firewall and D+ for programs you might have blocked that are suppose to be allowed.

I have had the same problem some time ago. My solution was uninstall CFP in safe mode, then install again. You’ll lose all your firewall and D+ training data and start from scratch again.

Of course my first try was to look for blocked applications in D+, but I wasn’t permitted to open CFP … In my case the problem was caused by an old game, a fullscreen application, which for some reason unknown to me wouldn’t allow me to minimize it in order to get at the pop up which was blocking it. So I killed it with task manager. Eh voila, no permissions anymore. You CAN shut down the system by the way via task manager. But after reboot it’s still the same. Of course you could do a lot to solve the problem, but with no rights to do whatsoever you’re simply out of luck. At least I ran out of ideas what to try. Maybe some more Windows savvy people could find a way, I couldn’t anyway.

tab

Does the current version of CFP work for you, or have you switched to an other firewall?

If this is what I experience a couple of months ago, I submitted a bug report here. There is also another report, where Little Mac gives a tip how you can solve this problem (scroll down a bit). I don’t know if it’ll work, but maybe worth a try.

LA

Yes, it DOES work for me. Because I now just pay much more attention not to run any full screen applications without switching to training mode when I’m not sure I’ve ru it before. But I still find it quite alarming that you can get in such a situation without doing something obviously wrong. And that I HAVE to pay attention or else will be forced to start over again. Not really good for peace of mind :frowning:

tab

Hi Nigel B,

If you are unable to solve your problem,you could try booting into safe mode(F8 while booting) and choosing “Last Known Good Configuration”

Hope you sort it.

Matty

ps you could give this a try, if you get to Defence+/Advanced/Computer Security Policy -remove the entry for%windir%\explorer.exe

Here’s something that worked for me.

  1. Boot into safe mode
  2. Run Comodo
  3. Click the “Defense +” icon
  4. Click the “Advance” button
  5. Click “Computer Security Policy” link
  6. look for %windir%\explorer.exe
  7. set it to “Trusted Application” if it is not (mine got set to “Isolated application”)
  1. Click “Apply”
  1. Exit Comodo
  2. Reboot

Bump Just had this happen earlier and got out of it the same way above poster did. So you dont have to uninstall. Probably alot of people have done this. If you accidently limit explorer.exe rights , thats what happens.