Local network, including a VM, gets blocked by CIS FW.

I am running W7 x64 with CIS 6.2.285401.2860. I recently changed from my ISP’s modem/router to a separate modem and router. This meant that now there were changes to IP addresses on my LAN. After that I could not see my host net shares from my VM (VMware Player) or a laptop on WiFi. After many really bad words, I discovered that it was CIS. If I closed it, access was restored. Closing only the CIS FW also allowed access. I tried many settings (global rules, net zones) with no luck. I found that changing the Application rule for Windows Applications for Out to In/Out allowed access. This looks dangerous to me so I went back. Today I removed CIS and reinstalled thinking this would allow it to discover my VM network. No luck. What is the proper settings/rules to allow access and still be safe? Thanks and enjoy, John.

I really need some help. I have exhausted my knowledge and patience. The latest I tried was to define two new Network Zones for my VM guest. I specified the IPv4 address and Subnet mask I see for the two virtual NICs on my host machine. I then added two rules to each of two Application Rules - System and Windows System Applications. The rules were one for each of the Network zones I created and allowed IP In and Out for the zones. I also defined two Global rules the same as the Application rules. I continue to get the error shown in the image. I removed the computer name for privacy reasons. I know the VM is reachable because I can ping it and when I open Network on my host the VM machine is shown. On one try I changed the Windows System Applications rule from Out to In/Out, as stated above, and this allowed access but seemed dangerous so I went back to the default Out only. I hope someone will be so kind to tell me where I am going wrong. Also tell me what I need to do after changing a rule. Do I need to close/open CIS, restart my host (requires shutting down my VM guest) or what? Thanks and enjoy, John.