Local connections stopped working

Since installing the latest update today, my laptop will not connect to any other pc on the LAN. It still connects to the Internet OK. It appears that the rules for connection are OK (Application Rules, Global Rules and Network Zones) . If I set the firewall security level to disabled, the laptop has full access to the LAN, no problem. So obviously the problem is somewhere in the firewall. I’m thinking that the rules have become corrupted, but have no idea how to proceed. Help someone, please!


Quick question, have you tried setting the firewall in learning mode, accessed the other PCs on the network, set the firewall back to the normal setting you use (safe mode) and seeing if you can access them again with the firewall fully enabled?


I put it in learning mode but it made no difference. The laptop would not see the other computers (& visa versa). One thing I discovered, though, before putting it into learning mode and after. That is that it does see the router, and only the router, when accessing it via the browser.

I wonder, is there a way to reset the learned items so that it will start learning all over again? I’d rather not do this, but if it solves the problem…


Can you show us screenshots of your Global Rules and for the application rule for System?

From what version did you update?

Here are those rules, attached. Hope this helps.

Thanks again.

[attachment deleted by admin]

The Global Rules look fine; they are how they should be. Did you use the Stealth Ports Wizard to create a trusted local zone?

The rule for System is the problem here. Like in Global Rules it should have two rules that define the local network as safe.

Try the following. First delete the rule for System. Then run the Stealth Ports Wizard and choose Define a New Trusted Network and Make my Ports Stealth for Everyone Else. Choose “I would like to trust one of my Network Zones” → choose Local Area Network #1 from the drop down menu and close with OK.

When done try again and see how things go. Also post a screenshot of the new application rule for System.

EricJH, :cry:

I performed the steps you asked, but that did not help. When attempting to access another computer via My Network Places > Microsoft Windows Network > Workgroup, the following error message occurs:

My Computer
Workgroup is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions.

         The list of servers for this workgroup is not currently available 

Every time I reboot the computer Comodo warns that System is trying to receive a connection from the Internet. I accept this, with the remember option checked, but get it the next time the computer boots.

Lastly, I have two connections to the network, wired and wireless. I have tried making this work with wired only, wireless only and both. Note that the list of networks to trust does not list the wireless network, but the system application rule appears to include it.

Attaching screenshot of new system application rules.

[attachment deleted by admin]

The rule for System has rules for two LAN’s. In what IP range is the LAN at the bottom? Notice that the rules under the Block and Log All Unmatching Request are not active. That is because CIS reads the rules top-down.

Drag and drop the two rules at the bottom to a place above the Block and Log rule. Then try again.

EricJH ;D

That did it! Both Wired only and Wireless only (& both together, of course) work now.

The definition for LAN#1 (listed at the bottom of the rules list) in the Network Zones list is the IP address for the wired adapter with the subnet mask

Thank you for your assistance in this. Would never have done it without you!!!