Local cloud file caches are virtualised & get deleted on reset [v6] [MN]


  1. What you did: I opened Kiosk, opened the shortcut to dropbox, closed kiosk and reset sandbox, gets an error that there is a problem, resets the sandbox again, open my dropbox folder(outside kiosk), and all the files is gone. (i am so happy they are backed up on the web, or they would be gone)
  2. What actually happened or you actually saw:
  3. What you expected to happen or see: That i would not be allowed to open the folder, or that it would be restricted somehow, as the sandbox suddenly now thinks all the files inside should get deleted to, when the sandbox is reset.
  4. How you tried to fix it & what happened: Tried to see if i could exclude it from sandbox/kiosk somehow, but just removed the shortcut from my desktop, so it’s gone from kiosk so i cant accidently open it in kiosk.
  5. If a software compatibility problem have you tried the compatibility fixes (link in format)?:
  6. Details & exact version of any software (execpt CIS) involved (with download link unless malware): Dropbox version 1.6.6 Download & Install - Dropbox
  7. Whether you can make the problem happen again, and if so precise steps to make it happen: see step 1
  8. Any other information (eg your guess regarding the cause, with reasons): Tried to open Dropbox virtualized outside kiosk, didn’t seem like anything bad happened there.

B. FILES APPENDED. (Please zip unless screenshots).:
0. A diagnostics report file (Click ‘?’ in top right of main GUI) Required for all issues): Attached

  1. Screenshots of the 6.0 Killswitch Process Tab (see Advanced tasks ~ Watch Activity) or 5.x Active Process List. If accessible, required for all issues:: Attached
  2. Screenshots illustrating the bug:
  3. Screenshots of related CIS event logs:
  4. A CIS config report or file: Attached
  5. Crash or freeze dump file:
  6. Screenshot of More~About page. Can be used instead of typed product and AV database version: Attached


  1. CIS version, AV database version & configuration: CIS v6.0.260739.2674, database version 14609. Proactive configuration.
  2. a) Have you updated (without uninstall) from a previous version of CIS: No
  3. a) Have you imported a config from a previous version of CIS: No
  4. Have you made any other major changes to the default config? (eg ticked ‘block all unknown requests’, other egs here.): No
  5. Defense+, Sandbox, Firewall & AV security levels: D+=Safe mode , Sandbox= Partially limited (i think, if its the autobox, or else i can’t find it) , Firewall = Safe mode , AV = don’t know how to see that in v6
  6. OS version, service pack, number of bits, UAC setting, & account type: Windows 7, service pack 1, 64 bit, UAC disabled, Admin Account.
  7. Other security and utility software currently installed: SuperAntiSpyware, MalwareBytesAntiMalware, jv16 Powertools.
  8. Other security software previously installed at any time since Windows was last installed:
  9. Virtual machine used (Please do NOT use Virtual box)[color=blue]: none, other then the virtual kiosk in CIS.

[attachment deleted by admin]

Thank you very much for your bug report in standard format. We very much appreciate the effort you have made to document this bug.

We are sorry to trouble you further but there are some items of information missing or unclear in your post

  • Section C, including CIS report and Killswitch process list

The reasons we need these items of information, though they may not seem directly relevant to the issue are explained here.

We would be very grateful if you would add these items of information so we can forward this post to the format verified board, where it is more likely to get fixed. You can find assistance using red links in the Format and here. If you need further help please ask a mod. If you do not add the information after a week we will forward this post to the non-format board. If this happens we will tell you how to rectify this if you wish to.

In the current process we will normally leave it up to you whether you want to make a report which includes all necessary information or not. We may remind you if we think a bug of particular importance.

Many thanks again


Is it okay now ?

That’s great, sorry you have had this problem

Best wishes


Whoever changed the title is wrong.

Dropbox is cloud so you can transfer files between computers without an USB stick, and every file deleted also get backed up in cloud to so you can restore them (thats how i got my files back)

But if you have it installed you get a folder on your computer, so the files are on the computer, and in the cloud, and whatever changed it made 1 place will get changed the other place, unless syncing is disabled.

What kiosk does is it REMOVES all the files in the dropbox folder that is ON the computer, so that dropbox have to download all the files from the dropbox cloud again.

So its all the files in “C:\Users\username\Dropbox” thats get deleted, or whatever location dropbox is installed to on the computer.

Does MN means its fixed? just tried to do the bug again, but now nothing happens, i can even access the files in the dropbox folder inside kiosk.

OK sorry misunderstood, that’s part of the reason for changing the title, helps in clarification.

Whether this is a bug or not needs some thought and discussion, hence it has no tracking number yet. [Mods No]= [MN]

If you run from Kiosk you are asking the Dropbox software to be run virtualised, meaning you want all files it creates locally to be deleted on reset? Otherwise you would run it outside Kiosk.

Obviously it would be preferable though if it did not cause a dropbox error. IN a sense maybe that’s because it did not delete the Cloud files too, so it found the cloud files, but not the local cache. It could have created a C:\VTroot in the cloud and then deleted it on reset. Then there would have been no dropbox error.

Best wishes


Best wishes


I just have no idea why i can not reproduce the bug now, the only change from the first times is i deleted the shurtcut, and made a new shortcut as i wanted to reproduce it again, to see if i could explain it better.

Now i can open dropbox inside kiosk, and access the files. Before it was just empty inside kiosk, and i am not sure the window would stay open, and then after resetting sandbox/kiosk all files was gone from the computer/dropbox folder to, and dropbox did redownload all the files from cloud immediately.

Before when i could reproduce the bug i also tried to do so dropbox didn’t get virtualized, and then all files was gone from cloud to, after a sandbox reset, so i had to use the backup thats made of the files in the dropbox cloud.

But i will come with more info if i figure out why the bug is gone now,

Thanks I appreciate the update.


For the time being I will move this to Resolved.

Thank you.