"local access only" when using the Comodo driver on Network Adapter

When connecting to a network I can never get internet access, instead “local access only”. I’m running vista on 2 laptops which exhibit this behavior with your product. One is running Vista Ulitmate x86, the other Vista Ultimate x64
I’m using product version: 3.5.57173.439, and have searched for updates to fix the problem before submitting this post. If I disable the Comodo driver on the network adapter that is connected through the properties dialogue, then my connection is revived (internet access).

A fine product, but a nasty bug.

Did you change any of the rules under Firewall → Advanced → Network security Policy. Either under Applications or Global Rules.

I too am having a similar problem. I have 2 computers. One is running Vista Premium 64bit. The other is Running Windows XP Pro.

The problem I’m having is every time the systems boot Comodo wants to make a rule for a new network connection starting with 169.XXX.X.X

I have to reboot the router so that it can assign a new IP address.

This is highly annoying. I had been using Comodo on the Vista machine for about 1 week. Then suddenly one morning this started happening.

The version of Comodo is 3.5.57173.439.

I have searched the forums for a solutions but the only thing that seems to have been tried is a static IP address. I have 5-8 devices that constantly connect and disconnect from the router. I’m not playing this game. I should be able to have it work correctly.

Some additional information;
Running Vista as Admin,

CPU, Core I7 920 on Vista, Pentium 4 1.7Ghz on XP
Comodo Antivirus & Firewall Free version, firewall running in Safe Mode

Any suggestions befor I go back to Norton?

Try running the Diagnostics wizard. It can be found under Miscellaneous in the main screen.

Can you also show us a screenshot of your Global Rules ( Firewall → Advanced → Network Security Policy → Global rules)?

I ran the diagnostics wizard and it said it didn’t find any problems with my installation. I have attached the global rules as you requested.

[attachment deleted by admin]

All right I must have missed him.

Questions where did you get the rules in the screen shot?

They don’t tell us much the way it is as It doesn’t show the IPs for the Zone.

Are you having the same problem on both PC’s?

If rebooting the router fixes it, reviewing your routers network settings is more likely a place to start.
5 to 8 devices so we’re talking wireless?

Bad F, I have 2 machines that are using Comodo, 1 is hard wired the other is wireless. They both need to have router reset once they have been rebooted to gain internet connection. I have an additional 5 machines + a slingbox connected that are not running Comodo and they do not have this problem. So I don’t see how it is the router.

The rules in the screen shot came from EricJH’s suggestion to show a screen shot of global rules in Comodo.

I use a Linksys WRT54G Router.

Can you show a screenshot for your network zone?

What happens when you switch the network cards of both the systems off and on? Does that work instead of resetting the router?

The reason I ask is that the problem is local and not on the router. So I wondered what happens when you reset the router. The NIC 's would get a new IP address from the DHCP server. The latter can also be forced by switching the NIC off and on or repairing it.

Attached is the image of my networks from within Comodo.

I have already tried repairing the nic. This doesn’t work.

It has to be Comodo. I know I have probably setup something wrong and duplicated it on both machines. My non-comodo machines have no problems.

I really appreciate your help.

[attachment deleted by admin]

You need to change the Global rules to use Network #2. The network #1 address gets made only when Windows doesn’t see a network; it will then make an IP addres in the 169 range.

You can delete the rule for network #1 as it only shows up when you don’t have a connection.

In my own network rules I add the broadcast addresses and to the range.

IF i did understand, you can solve this by including the MAC addresses of your NICs at your local network. This might help.