"Load at Windows Startup" option not working

I’ve been using Comodo backup on one machine v happily for some time now (version 1.04.337) but I’m struggling on my wife’s machine. I can change any of the settings except “Load at Windows Startup” - if I check the box and click OK, it doesn’t stay checked.
I’m running XP with SP3, as Administrator - if I sign in with my own Administrator a/c (the one I installed BU with, I think) no problem - but if I sign in with my wife’s a/c I get this problem.
Any thoughts please?

Hi marknw

It sounds like you need to be the admin that installed it, to change that setting in Backup or you may already have it running as a service.

However if you use service backup it will always be ready to run as it loads a service at startup - Cmdbksvc.exe. You will not need to have it load at windows startup, and your scheduled backup will run just fine. When you open Backup and are running a service backup you will see “service state” running.


I got the same problem as marknw, but with inconsistent behaviour. I installed Comodo backup on two machines (1 XP Pro, 1 W2K Pro) several months ago. On the XP machine there are two admin accounts, two user accounts. The “Load at Windows Startup” checkbox is checked in all four accounts and it remains checked in all four accounts. On the W2K machine, there is one admin account, one user account and the checkbox also works fine. So far, so good with backups working regularly on all six accounts. Just today, however, I created additional accounts on the W2K machine and I now have the same problem as marknw. The “Load at Windows Startup” checkbox will not remain checked (on any new admin or user account). I then created test accounts on my XP machine and there “Load at Windows Startup” works fine.

So in summary “Load at Windows Startup” has now stopped working for newly created users on my W2K machine.

Anyone have any ideas on what to do? It sounds like a bug to me. I am using 1.04.337.


Oh, I should mention that I checked services.msc and ComodoBackupService was running and on automatic. What I would like it to do is to for backup to load and to run the backup job when the user logs in.


Hi silverrope

Welcome to Comodo forums

You may want to try checking “start Comodo Backup” on the schedule page of your backup. This will run this job when Backup is started.

I don’t understand why the checkbox “load at windows startup” does not stay checked for you, especially when it is not on all machines.

Check out this post by panic - one of our moderators.