Сервер обновления под Linux

Доброго времени суток!
Решил сделать сервер обновлений на работе под Линукс.
Использовал информацию http://www.2dayadmin.ru/7-obnovlenie-antivirusa-comodo-cherez-lokalnuyu-set.html
Всё прекрасно качает,но вот на клиентах(версия 5.5) обновляться отказывается(настройки на клиентах как для обновления с COU).
Апач настроен следующим образом:
в корне имеется структура папок

/var/www/comodo/ /var/www/comodo/av /var/www/comodo/av/updates55 /var/www/comodo/av/updates55/sigs /var/www/comodo/av/updates55/sigs/bases /var/www/comodo/av/updates55/sigs/updates
и DocumentRoot /var/www/comodo

По идее вроде бы все должно работать,но вот не хочет,пишет при обновлении самого антивируса,что не удается найти указанный файл,при обновлении баз,что не удается обновиться…

Может я какие-то настройки упусти?
Подскажите,пожалуйста!

ОС Xubuntu 11.10
З.Ы.:из браузера папки доступны…

Haggard, не совсем понятно, кто пишет, что пишет, какой конкретно файл. Этот при обновлении баз или самой программы? Как при этом выглядят апачевские логи. правильно ли отрабатывает сам башевский скрипт и т.п. Это всё только с 5.5, или с любой версией? (или неизвестно?) Очень может быть, что 5.5 хочет базы в виде 7z-архивов, скрипт их не качает, как из него видно. Уточните всё это, если не трудно.

Пишет антивирус на клиентских машинах,как при обновлении самой программы,так и при обновлении баз,происходит как и с версией 5.5,так и 5.8.Башевский скрипт выкачивает базы и обновления самой программы правильно,помещает по правильному пути,да,не в 7zip,а в неархивированном виде…

Выкладываю логи Апача и также используемый скрипт.

[attachment deleted by admin]

Спасибо за ответ!Проблема решена,оказалось,что скрипт подчищает все рабочие директории,собственно в них всегда находяться только самые новые,а на клиентах базы были разных версий,они не могли найти нужные им,поэтому была такая ошибка…

В этом скрипте есть ошибки. Попробуйте установить новую версию с вышеупомянутого сайта.

Качну…
Ну его все равно нужно поправить))ИМХО,удаление старых баз не нужно,а то будет проблема как у меня…