Limited or no connectivity?

I have been using firewall version 2.4 for a few months now with no problems at all.
The other day I upgraded to V3.0. It installed fine removing the old version etc and went through the set-up.
After I re-booted my LAN and wireless screens on the taskbar had a yellow warning triangle with an exclamation mark saying “limited or no connectivity”.
Both connections showed activity but would not let me connect to the internet. Internet explorer tried to open a page but came up with page not available etc.
The Internet protocol (TCP/IP) properties have been tried on both automatic detection and entering the addresses manually but with no success. When entered manually I can get rid of the yellow warning triangles but it still won’t let me on the net.
Have tried installing a few times but it is always the same.
I am now back running V2.4 and have no problems.
Does anyone have any suggestions why this is happening and how I can overcome it?
I am running XP SP2.

Thanks (:WAV)