Limewire DC issue HELP! [Resolved]

Hi, I just installed Comodo Firewall today and It seems great!
Until my friend whom I was sharing files with through the Direct Connect feature in Limewire told me she suddenly could not connect to me anymore!
Then I’m going to give her a new DC number but notice I can’t get any and Limewire tells me I can’t connect like that due to a firewall or router blocking!
So I guess it’s COMODO blocking Limewire for me?
Even tho when I started Limewire I allowed it access by clicking allow in the popup.

I searched this forum some, and tried the advice with the rules for Gnutella but ether i did something wrong(and I need a dummy explanation :-[ ) or There’s something else I need to do.

I have some other spyware programs installed, Spybot S&D, Spywareguard and SpywareBlaster in case anyone knows if they’d possibly block this… but I’m betting it’s the firewall now actually.

Grateful for any help. Preferable in step to step advice red

PS: oh and should I keep the setting I had with Limewire to find settings for ports itself or should I direct it to one specific port (the 3646 or whatever)?

Welcome to the forum.
Network monitor works like a router, so you have to “forward” port(s),
like you do in a router, for apps like Torrent/P2P.

You should set up Limewire to use a port (not random). (choose between 40000-65000)
Disable any UPnP if there is a choice in the program.
Close Limewire.

Go to Network monitor (security/network monitor).
Right click on your top rule and add/add after.
Do these settings.

Action : Allow
Protocol : TCP or UDP
Direction : In
Source IP : Any
Destination IP : Any (or zone if you have one)
Source Port : Any
Destination Port : The port you have set up in Limewire

If it doesn’t seem to work, restart CF or reboot your PC.

Always remember to place your allow rules you make, above the default block rule.
Network monitor reads the rules from the top to the bottom.

Also check the log in activity/logs and try to see which rule that blocks your app.

I hope this helpes.
Also check the FAQ section for settings.

Thank you, and thank you very much for the fast reply!
I read on the forum and tried to configure my bittorent program to see if I could work that out, and suddenly the coin fell down and I understood how to do it, alas how to create the new rule, and to move down the block one.

So it works now!

But thank you anyway! ;D

You’re welcome. ;D

Something really weird happened when I tried to start limewire just now again.
I have probably not had it running since last time (not that i remember anyway) so I could have made something odd the last time even tho for some reason I got it to work then! ???
But now when I start limewire the Direct Connect feature is blocked again!
The rules in the network control have the red one in the bottom, and I checked the activity log and it tells me something defiantly went wrong.
It tells me rule 9 is blocking, but rule 9 is the red X one in the bottom, all the other rules are on top, so why could it be blocking then? ???

I have no idea how to solve this so I’d appreciate any help in the matter.


Do you still have the same ports set in Limewire? They haven’t been changed?
Have you checked so it’s not on random?

I had not changed ports in limewire and I don’t understand what you mean with random?

Hmmm, I was thinking… maybe the best thing is to remove all the rules I’ve added(there’s just rules for various file sharing stuff anyway) and start from scratch and re-add them.
But I’m wondering if someone could link me to somewhere where it’s told how it looked in the beginning(when there are no rules added except the default ones)or tell me which rules are default, as I have moved them around and don’t remember how they looked from scratch and which ones are my added and which ones are not. :-[

And as I’d love to not have to reinstall the firewall just because of this ::slight_smile:
Thanks in advance

You can click on my signature banner, and go to tutorials and run the noob install guide. In the end there are two screen shots of network monitor rules with or without a trusted network.

Thanks, I hope I can get it to work by redoing it. sigh
Thanks for the help, oh and great tutorial btw!

Good luck. :wink:

And it didn’t work. :frowning:

I really really need this to work until the 14th, but any earlier than that and it would be awesome.
I was thinking it might help if I included some screencaps…
my limewire settings

CPF rules list, the marked one being the one I made for Limewire.

And as I was told once to check the log I’m showing a cap of that too, and I think it’s the top log that’s shown in detail below. But tell me which one to click and what to do with the info and I will.
I started limewire to see if it worked, and I think a lot of the log entries a bit below there is due to that. But I’m not sure exactly which.

You can right click in the log and export as html. Attach it to your post.

You could try to change the port to a higher number. Try between 30-60000.
Do it in both programs and then reboot your PC. When rebooted, turn off all unnecessary programs, and start Limewire. Give it some time to connect, and also go to the firewall log and export it so you can post it here.

I changed the port to 65000 on both firewall and LW, and applied settings and then restarted the comp.
Turned on LW and only that except for virusprog. and so, but it would still not work.
so I exported a log. I hope I’ll manage to attatch it now also, heh…
…yep figured it out! :wink:

[attachment deleted by admin]

Try these network monitor rules if they work.
If they work you can put your IP if you have a static IP in the rules.
In the IN rule YOU ( are the destination.

Action : Allow
Protocol : ICMP
Direction : In
Source IP : Any
Destination IP : Any (
ICMP Details : Port Unreachable

Action : Allow
Protocol : ICMP
Direction : Out
Source IP : Any (
Destination IP : Any
ICMP Details : Port Unreachable

um… should I change the two ICMP in and oput rules I have in my default rules list to what you wrote above or should I create two new rules with these settings you showed me? ??? :-[
(better to ask than do something stupid)

Create two new rules.

If it doesn’t matter where the rules are put (as long as they’re above the red one) then it didn’t work. :frowning:

Does it work if you turn off network monitor?