Lexmark scan will not work with Firewall

Hi all:

Hope someone can give me a bit of advice. I have Windows Vista 32 bit and using a Lexmark x5470 3 in 1 fax, scanner, and printer. The unit work just fine until I install Comodo firewall pro. (freeware version)

Oh the printer and fax work fine. But trying to scan documents or printer just stops working and after a few minutes the Lexmark Imaging Studio software stops responding.

If I remove Comodo and reinstall the printer software the scanner works no problem.

Any idea’s on how to resolve this would be helpfull


Try putting D+ in training mode and running your printer software. First delete all entries of Lexmark in the D+. Go to D+/Advanced/Computer Security Policy and there you will see all your programs.

Ok, tried the D+ in training mode and deleted all entries of Lexmark in the D+. Even removed the printer software and did a complete reinstall of it with Comodo D+ in training mode and I am still unable to scan.

Any other ideas?

What do your logs say?

I had a similar problem with my Dell All In One scanner which is also Lexmark. In the device manager my imaging device (scanner) was flagged and I tried everything to correct it, including reinstalling the software and driver to no avail. I can’t lay the blame on CFP as it just stopped working one day months after having CFP.

Anyway, long story short, as I intended anyway since my laptop was nearly 2 years old, I reinstalled XP, drivers, programs including the Dell printer software and CFP, etc and it started working again.

On a side note, I backed up C drive (system) once XP and all my drivers were reinstalled and once again when my programs were reinstalled using Seagate DiscWizard (Acronis) to an external drive to make reinstallation easier. My Documents reside on D drive which is also backed up separately.

Best of luck…