Lexmark Printing Software

I noticed BOClean (pretty certain it’s BOClean) has been silently blocking proper installation of the Lexmark x3550 series. When the hardware wizard ends, the error explains that the process is already in use. To make a long story short, when I disabled BOClean from starting up and monitoring the computer, the printer installed fine. I would still like to use BOClean but can not until it works nicely with Lexmark Printing Software. For your reference, I am using the Lexmark x3550 Inkjet Printer (I also use a Lexmark E322 Laser, but this requires no Lexmark software and works fine.)



Thanks for your feedback, I have reported this to Comodo.

After you disabled CBO and successfully installed the Lexmark software/drivers were there any problems running CBO?

No, no errors from BOClean. However, I recently shut down BOclean and disabled it from monitoring, but enabled the firewall. Still, when I try to print, there’s a problem communicating with the printer. I check the Firewall’s logs, and nothing from the printer is logged. I check to see if anything in application/component monitors are blocked, but nothing is. Could someone let me know which .dll’s/programs I must allow in order for the printer to work with Comodo software? (:WIN)

I even tried disabling the Firewall service and process from startup just to see if that would let the printer print, but no. I rebooted with NO comodo software running and still received the Problem Communicating with Printer window after trying to print. (Before, once I installed the printer without any comodo software running, it worked. However, when I rebooted with Comodo software [firewall/boclean], the printer ceased to print [although, computer would still recognize-and Accessories>Scanner and Camera Wizard would still work with scanner-just not Lexmark Software]. But now, even after I disable all comodo software again, printer will not print. Only possible fix I know of is to uninstall and reinstall without Comodo around)

Any help would be greatly appreciated…

This sounds like you got off on the wrong foot from the beginning with your printer software and driver install.
I’m not sure when or where CPF came into the picture during this process.

Is the printer shared on a network?

Start over, uninstall CBO* , CPF and your printer software/drivers. Please read all pertinent uninstall guides first.
*(see the FAQ)
Reinstall and configure each application starting with your printer. You will want to reboot and make sure each one is working prior to installing the next app.
If you run into problems then, let us know and we’ll go from there. :wink: