Lenovo Thinkoad: Mute-Button freeze


recently I updated Comodo to with the internal updater.
Since then my PC freezes, when I press the mute-Button.

It’s a Lenovo Thinkpad T61p.

Any advice?


I highly drought this is a CFP 3 issue. Can you try uninstalling and test mute button, then reinstall.


PM998, welcome to the Comodo forums.

FWIW, my IBM T43 ThinkPad does not exhibit this behavior with the latest version of CFP.

Are there any relevant entries in your Event Viewer log? Check your audio and sound card drivers in Device Manager for any yellow warning icons.

CPF is defenitifly the issue. When I uninstall CPF everything works fine.

The event log is empty. I think this is because of the crash, every time I press the mute button.
CPF is not able to write something in there.
Two interesting things:
1.) The two volumn control buttons are working fine.
2.) The mute button in windows volumne control window freezes the system as well.

Thanks for your help

Hi PM998:

What OS are you using? I have used CFP3 on my ThinkPad R60 with XP SP2 and SP3 without experiencing your problem.

I recommend you contact Lenovo tech. support or visit the ThinkPad forums, and try to find out which executable file(s) are supposed to be triggered when you press the mute button. Once you have that, then perhaps folks here can help you determine if your HIPS/Defence+ settings are somehow blocking these executables.

I have the same problem.
My notebook is Lenovo Thinkpad X61.

After I updated the Comodo Firewall to last week,
the windows freezed after login (when it started to load the firewall software).
The only way I can do is power off and restart the computer.
So I uninstalled it, and installed again with the latest version,
this time it freezed with the volume control (both the mute-button and the windows’ original volume control).
After many trials, I gave up and uninstalled this firewall, then everything’s ok.

That is rather bizarre behavior that is seemingly restricted to the T6x series of ThinkPads. What on earth could be causing it.

Do both of you (PM998 and ah985) have the same sound card? Sounds like the HIPS function in CFP is interfering with the sound card drivers. Or audio-related DLLs or OCXs. It’s certainly an interesting, but irritating mystery.

I think we have the same sound card,
actually for notebook, it is all Intel-integrated Santa Rosa,
The driver for the integrated sound card showed
“SoundMax Integrated Digital HD Audio”

But I don’t think it is the problem of the sound card
since this is a standard equipment.

I will wait the next version to see if this problem can be resolved.

I could identify the problem.

It is caused by the OnScreenDisplay from the Hotkey-Package of the Lenovo software.
There are two processes:

If you kill these two processes, the mute-button works again.
I think it worked already before, but the OSB crashed the PC directly after it was pressed.

Any suggestions how to fix the problem properly?


Well, you’ve narrowed down the problem, if not the solution.

Shutting down those two processes after system startup might serve as a temporary workaround until the next version of CFP is released. It’s not much of a fix, but at least you’ll be able to use the Mute button.

Of course, there is no guarantee that the problem won’t persist after the next version of CFP is released. However, I doubt that Lenovo will issue a fix – indeed, it may not be their fault – anytime soon. I’ve never heard of any other ThinkPad users experiencing this problem outside of the T6x series. Why this bug affects that edition and not the T4x ThinkPads is beyond me.

You can try adding those two processes to your Safe List and Trusted Applications list, but I doubt it will permanently resolve your issue.

I have discovered the same problem today on my Thinkpad T61p today too. Maybe we can initiate a crash via the keyboard and look at the crash dump and see what system call was last executed as the keyboard appears to work after the freeze.

Spmfltr, welcome to the Comodo forums.

Excellent suggestion…this is shaping up as a very strange bug. I wonder if it might also be worthwhile submitting the contents of the crash dump to Lenovo?

Good idea. However, nothing seems to be crashing.
The PC gets stucked and finally stalled, but no program is crashing.
Dr. Watson has not saved any crashdumps.

Are there other methods to save such a crash dump?


Peter, the only other thing I can suggest is to copy any information that might be appearing in Event Viewer that is related to your issue.

If you click on a specific event in EV, it presents a separate window whose contents can be copied by clicking the button just below the directional arrows.

Let’s hope this problem gets fixed in the next release of CFP.

Ok. Now it becomes interesting.
I think the first suspect (Lenovo) is cleared.
It is true, that the laptop does not freeze, when the Lenovo Tools are uninstalled.
However, the mute-Button does not mute anymore. It simply does nothing.

If the “mute”-Box in the sound control is clicked, the Laptop freezes again.
So the problem is caused by the mute-Function of the driver or windows.
The Event-Log show not suspicious entries.


PS: I just tried the last couple of releases. The error appears first in The previous version are working alright.

Hi all,
I have the same problem wit comodo on R61. I installed it yesterday(after Symantec has expired) and it freezes with mute button, but also when a I try to mute via sound icon in taskbar. After uninstalling all is going ok.

Vladi7, welcome to the Comodo forums.

Please also report your issue to Lenovo, if you haven’t already. Yours makes at least the third confirmed instance of this problem. The more Thinkpad users who complain to Lenovo about it, the more likely they will get off their duffs and see if it is caused by a ThinkVantage or Lenovo application.

FYI: I was surprised to use Thinkvantage Update Service and discover after installing the latest TPO*.exe versions, the problem appears to have been fixed. I have been avoiding pressing the MUTE button, so I didn’t take notice until I noticed they changed the volume up/down behavior to now stop at 1, the TPO*.exe that locks up goes down to 0.

Hi spmfltr,

could you give me some details about the version you are using. I installed the latest one from the Lenovo website and still get the same problems with the latest CPF.
The lenovo version is
Version: 2.07.1005
Release Date: 2008/04/07


Not sure what you have versioned, but my TPONSCR.exe is and TPOSDSVC.EXE is

The major difference is that the volume does not go down to 0 if you hold the button it stops at 1.