left hanging on the user account 'welcome' window after installation 'restart'!

I’d really like to use Comodo’s Internet security suite but am having immediate problems.

Tried to install CIS 3.13 on Vista.
All seemed OK using the wizard up to the point where I was instructed that “installation successful, restart computer to complete installation”

Upon restart & then signing into my user account I am then left hanging on the ‘welcome’ window directly after signing in.

The only way out of this was to turn the computer off and then restart in safe mode where I could then use system restore to regain the previous state.

I thought that maybe the problem was because I’d chosen to use Comodo’s DNS settings choice in the wizard, maybe it couldn’t authenticate a user license!, so attempted installation again without choosing that option, to no avail. Again I was left needing to turn off, restart in safe mode, system restore.

Prior to this experience I had used Revo Uninstaller to remove all traces of my previous security - Kaspersky Internet Security.

Any help or mutual experience gratefully received.

no it has nothing to do with DNS…it can happen when Def+ blocks something (what exactly I have no idea) and the result is you can’t login or you’re logged in on a temporary profile, your own profile is somehow marked as corrupted by Windows, and it’s not in fact (has happened to me on Seven), after a fresh CIS install and reboot. You shouldn’t have restored your system so quickly… the thing is I don’t think CIS is accessible in safe mode as it needs a driver…the UI is probably not accessible either.
You should clear anything left from CIS (in the registry too) and attempt a new install. Don’t chose something too extreme during the setup, “firewall security” should be enough, you can change this later if needed. This should at least allow you to login without any problem after the install and reboot.

Thanks for your response,

Tried re-installing several times, even just installing (the less extreme) one item (AV) as suggested but to no avail, still left with the same problem!

Instead of restoring as before, while in safe mode I also tried just using Revo Uninstaller to remove, which worked and also allowed me to reboot in normal mode.

Out of interest the UI is still accessible in safe mode.

What am I to do next?

honestly I have no idea, could be that CIS is conflicting with something else, see your other security software…

The UI can be started in Safe Mode. That will allow you to set things straight in case a settings did something you had not expected.

Before rebooting did you enable “Block all unknown requests when the application is closed”. That can sometimes do fishy things. Do the Defense + logs show that they are blocking something during boot time? Please a screenshot of the logs. They are under Defense + → Common Tasks → View Defense + alerts.

To be sure there is no driver left of previous uninstalled security programs do the following.

We are gonna take a look to see if there are some old drivers of your previously uninstalled security programs are still around. Go to Device Manager → View → show hidden devices → now look under Non Plug and Play drivers → when you see a driver that belongs to your previous security programs click right → uninstall —> reboot your computer.

When the problem persists make sure there are no auto starts from your previous security programs. Download Autoruns and run it.

This program finds about all auto starts in Windows. This tool can therefore seriously damage Windows when not handled properly. After starting go to Options and choose to hide Windows and Microsoft entries, to include empty locations and then push F5 to refresh.

Now check all entries to see if there are references to your previous security program. When you find them untick them. After unticking reboot your computer and see what happens.

Hi Eric, apologies that I didn’t respond to your help right away, I’ve been away for the past week!
I really do appreciate you taking the time out to help.

I’ve had a good ■■■■■ at your suggestions, in fact I’ve been going round & round the houses for hours (Up all night, now 10:20am)

First off went to Device Manager → --> Plug & Play drivers, & found one Item of Kaspersky which was then uninstalled.

Next used ‘Autoruns’ & found Quite a few instances of Kaspersky, of which a few could not be “unticked” at first, but after going back and forth between Safe Mode & Regular & also using Revo Uninstaller again and carefully going through all registry Items finally managed to get ‘Autoruns’ to accept de-selection of the last Kaspersky items.

Also checked that there were no previous scraps of Comodo remaining before attempting Installation of CIS once more.

Before rebooting to finalize install, accessed UI & “Blocked all unknown requests when application is closed”.
Then accessed defense logs to get you a screen shot but got the message “There are no Items to show”.

Re-booted to finalise install and . . . . , same problem, left hanging on the welcome screen once more!?

Rebooted in safe mode, accessed UI & again tried to get a screen shot from the defense logs but once more got the “There are no items to show” message.

I’ve since tried this again & again, checking & re-checking my steps, but always coming across the same problem, the only thing I’ve achieved is getting wired on strong coffee!

Anyway I’m pretty sure from this approach so far that I’ve done all I can.

Any more suggestions would be most welcome.

Bit confused, but this may be of further help!?

Even though I had uninstalled KIS using ‘Revo’, uninstalled remnants in Device Manager → Plug & Play Drivers
& also then used ‘Autoruns’ to deselect any remaining instances, Kaspersky is still referred to in several instances within the ‘Windows Security Center’ window?!

When trying to install ‘CIS’ I had disabled Windows Firewall, but, within the Windows Security Center;

Informed under Firewall
Windows firewall & Kaspersky Internet Security both report that they are turned off.

Even though when appropriate Windows Defender was turned off (esp’ 2nd point 'Spyware & Other…);

Informed under Malware Protection
Virus Protection
Kaspersky Internet Security reports that it might be out of date. Kaspersky Internet Security has not provided Security Center with a program to fix this issue.

                      [u]Spyware & Other Malware Protection[/u]
                      Kaspersky Internet Security Reports that it is turned on.

Directly underneath this is the link “Show me the antispyware programs on this computer” & when accessed it opens the small “Installed Spyware Protection Programs” window & the information shown there is as follows;
Kaspersky Internet Security On
Spybot Search & Destroy Out of Date (Although just installed!)
Windows Defender Off

I can’t access Kaspersky from here to turn anything off?!, or anywhere else for that matter!
I just don’t understand . . . .
& the coffee’s waring off

But does this shed any more light on the situation?

To get rid off the Kaspersky reference in Windows Security Center do the “Windows Security Center reset”:
Open a command prompt by clicking Start → Run. Type cmd and click OK.

In the command prompt window, type NET STOP WINMGMT /Y and press ENTER.


Type EXIT and press ENTER to close the window.

Restart the system. Windows should start normally, but you may be prompted to restart the system once more to complete the changes caused by resetting the core repository. You may also need to restart once more if Windows Security Center still does not detect your security product.

For the other problem try disabling “Blocked all unknown requests when application is closed”.

OK, this could be looking promising.

Quick pointer though, I put the first two commands in & stopped there.

After the first I got; SBSD Security Center Services
Security Center
IP Helper

                  System error 5 has occurred.

                  Access is denied

After second command got; Access is Denied

How do I get permissions in command Prompt?

I am used to running the command prompt under and admin account. You can try the following. Look up cmd.exe in c:\windows\system32, right click and choose to run as admin.

For the other problem try disabling “Blocked all unknown requests when application is closed” in case that is enabled.

Thanks Eric,

stumbled on the solution for admin status in command prompt in the start menu, shouldn’t have asked! :stuck_out_tongue:

Really thought I’d have it licked this time but problem persisted as before, after all new angles.

Booted up in Safe Mode, uninstalled, rebooted and then installed once again but instead of clicking “Finish” to restart the system, hung around to have a look in the Comodo UI & Windows Security Center.

In Comodo Noticed (as before) that under SummarySystem Status; stated " Comodo Internet Security is being initialized . . . . , please wait while the operation is in process.

So left it alone and accessed the Windows Security Center, . . . .
Where, . . . . .“Windows did not find anti virus software”

In fact there was no indication anywhere that the Windows Security Center had detected or recognised the Comodo install!?

Went back into the Comodo UI where SummarySystem Status has now changed and the information provided is that “The Defense+ is not functioning properly! Please run the Diagnostics utility to fix the problem”, but when I did so was informed that “The Diagnostics utility did not find any problems with your installation” yet the System Status remained on “Big Red Cross - not functioning properly” !

Again went to Defense+ events log but the message remained “There are no items to show”

Of course when I’d had enough of rooting about and rebooted the computer, was left hanging on the welcome screen

It seems you are running as limited user. Does the following help?

Try updating the Comodo Internet Security Helper Service (control panel, admin tools, services, right click on “Comodo Internet Security Helper Service”, properties). The logon Tab for the Service should currently show Local System Account and Allow service to interact with Desktop. Set This Account with your Logon ID and Password (+Confirm) and then reboot.

Reinstalled CIS & then went to control panel → admin tools → services, but there is no reference to Comodo at all in there!

Also, by Logon ID and password, do you mean that which I use to Login to my computer user account?

Please check the Windows Eventlogs for error’s that could give a clue about what’s going on.
There should be Errors in system and/or application logs… like services failing to load etc…

Do you have any other security software installed on the system, no matter real-time or on demand?


Provided attachment of file containing Event logs.
I’m afraid they mean little to me!

Other security; Windows Firewall, Windows Defender & Spybot Search & Destroy.

[attachment deleted by admin]

Also this screen shot & a particular event that I think is important, I may be clutching at straws!

[attachment deleted by admin]

Do you have S&D TeaTimer or what ever the name is activated?

And can you uninstall CIS and see if you can do a clean boot, and then check if a boot from that point does not show all the red ERROR in the eventlog?

We have to make sure the system is “clean” before we can start to check if CIS is the root cause here.

I took a quick preliminary look at your report. Some of the alerts mention that certain services could not start due to depencies. Did you recently disable services as adviced by web sites like the Black Viper?

It also looks like certain files are missing or corrupted. Were you hit by malware recently?

@ Eric;- I have not disabled any services as advised by anyone, I am ignorant to Black Viper. I am also unaware of any missing or corrupted files & have had no problems with malware as far as I know, if that helps!

@Ronny;- I could not find a means to deactivate the “Tea Timer” facility in Spybot, may run by default, so uninstalled Spybot alltogether.

Then did a clean install of CIS once more, . . . . . resulting in the same problem. So uninstalled it in safe mode once more.

Have included two more screen shots of all error action during these changes.

Time line as follows;- 17:27 Uninstalled Spybot
17:46 Clean install of CIS
17:50 Restart to finish install
18:15ish Manual shutdown due to the same persistent problem reoccurring
18:18 reboot in Safe mode, uninstall CIS once more
18:20 reboot in normal mode

[attachment deleted by admin]

I think if you uninstall CIS and reboot twice you will still have issues with red alerts, can you try to see if those DCOM errors disappear? those are not normal and are known to cause heavy issues…