Leaktest Failures

Hi everyone,

Has anyone tried all 19 of the downloadable leaktests at:

http://www.firewallleaktester.com/ ?

I’m in the process of trying them all with CPF 2.3 and I will post my results later when I’m done.
Before I get to far, I’d like to mention that CPF did not pass the test from tooleaky. This either
means I have CPF configured wrong or CPF’s outbound filtering is not that great. Setting the
CPF level to block all is reflected by tooleaky1.jpg and tooleaky2.jpg if the level is set to custom.
The second snapshot says my firewall is a cruel joke and useless :slight_smile:

My understanding is that having your firewall “trust” internet explorer is not always a good idea. but
sometimes I need IE to browse websites when Mozilla doesn’t render them correctly. So how does
one configure IE to be the least pain and still have CPF protect me against leaks?

In the application Control Rules. IE is set to (any any TCP/UDP in/out Allow)
Another app I’m not sure about how to configure is explorer. I would like to make sure
CPF is configured correctly before proceeding.

Tips appreciated…
Thanks, Al

[attachment deleted by admin]


Can you try the failed test with ‘automatically approve safe applications’ turned off.


Tooleaky is one of the simplest tests that CPF is passing starting from its first version:)
I am sure you have something wrong :slight_smile: It is also not related to Auto approve safe applications. Make sure in the applicaton monitor, you dont have iexplore.exe rule with “Skip Invisibility check” and “Skip parent check” options enabled.

Hope this helps,

Yes, that is why I was surprised that CPF failed. Anyway, here are some snapshots. Looks okay to me. FYI I’m talking about the beta … maybe a bug slipped in somewhere… I do not have auto approve
safe applications active.

If you need any other info logs etc. let me know.


[attachment deleted by admin]

[attachment deleted by admin]

Hmmm. Thank you for the feedback. What is your OSMode value?


AppCtrl has OSMODE set to zero. I set it to 3, but have to reboot. Maybe that will work. Hold on
a minute.


Can you also post your OS information(service packs etc) and other security applications installed?

Something is not working the way it should. After logging off/on again, I did get an explorer popup (not IE) running the leaktest. This is not consistent though. The last time I logged off/on, I did not get a pop-up. running leaktest. I also rebooted – similar results with OSMODE=3. Also, it seems that permit or deny is remembered for the entire FW session instead of a only a single time. Is this WAD?

“Remember my decision” should create a rule, which I understand. If I do not select this, I should get a pop-up each time I run the leaktest right?

Another thing that bothers me is that selecting allow/deny for a pop-up doesn’t show up in the log. I have no record of what I’ve done. There should definitely be an option to log all pop-up alerts and the answers. selected.

I have XP Pro with SP2 and most of the updates that have been offered by windows update service. Norton AV Enterprise 9.0, Spybot Search and Destroy, LAVASOFT Ad-Aware SE Plus. I have a feeling CPF can’t deal with IE :slight_smile:

Thanks, Al

It seems CPF does not operate on that computer. The basics are not functional. What about the version

The reason I’m trying the beta in the first place is because the installer for failed (1628). :frowning:
Oh well, I’ll play around a bit more to see if I can make any sense of all this.

Unanswered questions:

If I do not select “remember my decision” and then either allow or deny, how long will this selection for the pop-up be remembered?

Is there a way to log all pop-up alerts and the selections?

Ciao, Al

Followup in https://forums.comodo.com/index.php/topic,738.0.html

Thank you for your patience.