Latest Version CD running

First, I apologize in advance if i’m posting in the wrong spot. I’m not very saavy using forums of any sort.

Yesterday, I received the request to update CD to 42.2.2…which i did.
Now, when I try to run it, I get an error message "Whoa! CD had crashed. Restart?

I removed it with Revo and tried twice again. Same error.
Im running Windows 7 64-bit on an Acer laptop.
I also tried by disabling my AV.

It did install and run successfully on my Vista PC.
Thank you.

Hi and welcome retirednow48,
I suspect you are using high DPI settings.
There appears to be a bug when the system DPI is set to 150% or above.
Hopefully Comodo are working on a solution.
Please see the topic in the link below.
Chromodo Crashes Upon Second Use


I am having a similar problem, but the high DPI settings aren’t the cause in my case. My settings are at 125% and were before and after the install.

I installed this new version yesterday and now some websites automatically crash Comodo when I visit certain areas of them.

From the look of things I am going to have to uninstall this version and revert to the earlier one.