Latest update killed my connection - uninstall dont fix it

Hello.

So I installed the latest update today, rebooted and then my internet connection did not work. I tryed messing around with some of the settings, disabled the firewall etc etc but nothing worked. So I reeboted a second time, still no luck. Then I decided to uninstall CIS and simply make a fresh install. After uninstall i rebooted, but then my internet connection STILL wont work. So i thought it might be some rests of the program left and that was what was causing the problems, so I runned the batch file that supposebly should remove all left files and reg entryes from comodo and then restarded. But no, connection didnt work now either.

So last resort then, a system resstore. I restored my system to a point of about two days ago when I had not messed with CIS and everything was working fine. But no. STILL NO F*****G CONNECTION.

When I check the integrity of CIS via the misc tab (now after system restore) it says something is wrong, but it cannot fix the problem. Ive read on the forums a couple of months ago that a uninstall can kill the connection for some reason, is that what have happened? What do I do now? Please help me out.

OS: Vista 32-bit
NIC: Integrated in ASUS P5Q Pro, dont know exact model.
Been running CIS (firewall and D+) for at least three months and everything has been working fine until now.

Sorry for my bad english and poor explanation. What have happened is simply that: the update killed my internet connection, a uninstall dont help nor do system restore.

Alright so it seems I have solved it myself… I did a system restore to waaay back and now it’s working.

However, the diagnostics tool still reports problems that it can not fix. CIS also prompts me to use the update feature to update to the latest version. But since everything got messed up the last time i tryed I guess it’s better to uninstall and make a clean install. Now I am just wondering before i uninstall, is it a known problem that the connection may be disabled after uninstalling CIS? Is it something that I can do to avoid this problem?

I am attaching the diagnosis report if it helps.

EDIT: Ok, so I did a bunch of restore points and then started to uninstall and update to the latest build. Everything went fine and is working accordingly now. Sorry if I wasted someones time by doing this thread, it seems I was able to solve it myself. Anyway a little protip to vista 32-bit users: Do not use the update function in the program, manually unsinstall and reinstall the latest version.

Peace, take care.