latest rules version

Shouldn’t the new rules version be set to a number higher than 1.23 ? It currently published as 1.22 and I am not getting it on my servers.

https://forums.comodo.com/free-modsecurity-rules-comodo-web-application-firewall/rules-updates-changelog-t101377.0.html;msg792948#msg792948

Unfortunatelly description for Version 1.23 - 2014.12.29 was published earlier than description for 1.22

Current version available is 1.23 (Apache), 1.19 (LiteSpeed) and contain extended rules categories.

If you have version 1.23 this means that you already have all necessary changes made in 1.22.