:( latest CIS, firewall failure, diagnostics fine

I had been under the impression that my engine was being updated, but upon seeing repeated “108” internet connection failures in downloading virus signatures, I got to these forums and saw that I was at 3.558(?) and that the latest is 3.13.xxx
So per forum thread instructions, I downloaded 3.13, installed it (it uninstalled earlier version/ rebooted my system, then I ran it again and it installed) and now
----the main panel shows a status of “please wait” initializing CIS and then I get the error icon in the tray, and a note that the firewall is failed, “run diagnostics”
—which I did. no errors found.
—tried to update the virus DB from both the summary and antivirus panes, but get an error “Update Failed. error code 0x80004002. no such interface supported”… this isn’t good. :-[

I cannot update virus signatures and I have no firewall.

Hello brrrknee, I suggest you use Revo uninstaller and uninstall comodo. then re-install.

Hope this helps.