Language issue and error during installation

Hi, I have 2 issues during the installation process:

  1. Some of the language appears to in Arabic and I have no idea why. I choose English in the language installation menu. See example:

Also, while the program was running some of the labels were in Arabic, but most in English.

  1. I uninstalled, and now I can’t reinstall as I’m getting the following error message:

I also used the forced uninstall tool, but I’m still getting this error.

I’m using Windows 7 Home Premium 64 Bit.

Any help?

To get rid off the 1603 try running Windows Installer Clean Up utility. This tool cleans up all Windows installer related traces from your computer. It will allow you to run an (un)installer where it was getting blocked because it couldn’t find a needed file or says the products is already installed.

This tool does not uninstall a program.

What are your default language settings for Windows?

Windows Clean Uninstall didn’t find any trace for COMODO. However, I did find a folder that I can’t delete, not even after restart:

C:\Program Files\COMODO\COMODO Internet Security\Quarantine

Many that’s the problem? if so, any idea on how to delete it?

As for the language, it’s English.


Hi gogetit,
This unofficial Uninstaller Tool for Comodo Products is worth a try, please follow the instructions.
Good luck.

The Quarantine folder is protected from being accessed and deleting by rights management.

You need to do a take ownership procedure to get the needed rights to be able to delete it.

I’m unable to take ownership on that folder. the procedure fails. I searched, and it looks like a repeated issue with Window 7 Home Premium [I’m the administrator of course].

I have yet to find a solution that works for me. If someone knows, please let me know.

As you can see the image below, Windows Unable to display current owner., and the next steps of replacing the owner fails due to lack of permissions.

EDIT: I also tried changing the installation location, but I still get the same error.

Hi gogetit,
The link below has a few different methods for taking ownership.
I have personally used Method two/option one (Through the Command Prompt) and it has worked for me in the past.
Please consider any notes or warnings with the different methods before proceeding.

Okay, I was able to take ownership and delete the folder in Safe Mode. I was then able to complete the installation.

However, it seems that I have more issues, which might be the same.

  1. On the left side of CIS screen I get the message:
    COMODO Application agent is not running! Run Diagnostic.

When I do that, I see there are some problems found with the installation, which the application cannot resolve. I was offered to create a diagnostic report and it is attached here.

  1. [And this may relate to the #1], When I try to update the virus database, I get the message: Update Failed. Insufficient system resources.
    I’m utilizing right now 5% CPU and 30% [out of 8GB] RAM. So I think the problem is elsewhere.

Thank you for your help so far.

[attachment deleted by admin]

Hi gogetit,
Have you rebooted since final install?
If yes,
Check in Windows task manager (Show processes from all users) to see if both cmdagent.exe & cfp.exe are both running.
Check Windows services to see if Comodo Internet Security helper service is set to Automatic start up.

cfp.exe is running. cmdagent.exe isn’t.
Also, I couldn’t find a service call COMODO in the list of windows services.

Yes, I rebooted several times after the installation.


If windows services isn’t showing the service in the screenshot, something has gone wrong with the install.
Without this service the system is vulnerable.
Have you any other real time Security programs running?

This is possibly getting frustrating, but I would suggest a clean un-install/re-install with reboot in between.
I will also ask the other Mods to take a look at this topic.
Sorry your issues are continuing.

[attachment deleted by admin]

Alright, not your fault really. I had good experience with COMODO in the past and on my other computers. I will try to reinstall it again.

As for other real time security programs, no, I uninstalled them all [it’s a new laptop, came with McAfee, which I uninstalled prior to COMODO installation].

Not sure if it’s related, but COMODO does not categorize any process to be safe [not the usual behavior, I would assume, because on my other PC it says something along those lines: “chrome is trying to access the internet… chrome is a safe application, etc.”]

With McAfee coming pre installed, I would consider running their cleanup tool before re-installing CIS.
Clean-up tools here.

To add to captainstick’s advice.

Best thing to do to make sure that there are no left overs of previously uninstalled security programs around. Not all uninstallers do a proper job. And left over applications, drivers or services can cause all sort of “interesting effects”.

Following are two of my tutorials to make sure there are no more left overs.

Use existing removal tools

Try using removal tools for those programs. Here is a list of removal tools for common av programs: ESET Knowledgebase .

Otherwise do a Google search with terms “removal tool” and * name of product or vendor*.

For a more technical hands on approach:

We are gonna take a look to see if there are some old drivers of your previously uninstalled security programs are still around. First run "set devmgr_show_nonpresent_devices=1’ without the quotes from the command prompt.

Then go to Device Manager → View → show hidden devices → now look under Non Plug and Play drivers → when you see a driver that belongs to your previous security programs click right → uninstall —> reboot your computer. You need to Google the driver’s names to see to what programs they belong to. You don’t want to uninstall Microsoft/Windows related drivers of course; some Microsoft drivers may show up as non active please don’t uninstall them. It is best to make a system restore point before this of course.

When the problem persists make sure there are no auto starts from your previous security programs. Download Autoruns and run it.

This program finds about all auto starts in Windows. This tool can therefore seriously damage Windows when not handled properly. After starting push Escape and go to Options and choose to hide Windows and Microsoft entries, to include empty locations and then push F5 to refresh.

Now check all entries to see if there are references to your previous security program. When you find them untick them. After unticking reboot your computer and see what happens.

Thanks for all the help. I cleaned up using several cleaning tools, like the one mentioned above, Revo, etc. Reinstalled CIS, and everything seems in order now.

Thanks again, I think the trouble worth it, as this is a great product, and I have very good experience with it.

Glad you got it fixed. :-TU

I am also glad to hear that it is fixed and thanks for your help EricJH.

Same problem. More than that, after install, arabic language appear when you have to chose from the list of “Trusted” or “Installer” at “More Options”. I have Romaniaj language as the OS language and English as Comodo Language, Firewalll dna Defense+ only. I think this is an English language package problem.

It probably is. I had to change the OS language to English for the installation, as it seems some parts of it ignore the first window language selection.

Just for testing purposes, I selected Spanish for the installation, to see if some labels will be in Arabic, but there weren’t - everything was in Spanish, so obviously it has something to do with the default English pack [and maybe some other packs as well].

After I changed the OS language, it worked fine.

I found the problem: the Comodo Internet Security installer. There was a faulty version of it in the first days of 5.9 launch. I downloaded it and it had 58 MB (it was not the Firewall only installer). Now it has 82 MB and it doesn’t have this language problem. So redownload the installer, check that it has 82 MB, uninstall and reinstall Comodo Internet Security or just the firewall.
As a note, I used the full Comodo Internet Security 5.9 installer, I don’t know if the web installer solved this problem(Firewall only one seems to be fine now too), so try installing with the full general or the firewall only installers.