Language & Input Settings - Comodo Dragon Browser 33.1.0.0 version ~ PROBLEM.

I am unable to download the spell check dictionary for English United States Language. The error message states that the download failed. Any help will be appreciated. Thanks. Mr. Craig E. Whittington (Sydney NSW Australia.)

Hi and welcome craig-e-whittington,
I am unsure why the dictionary won’t download, there can be many reasons including firewalls or security programs blocking the download.

I will post a workaround below.
Attached you will find a zip folder containing the ‘en-US-3-0.bdic’ file.

  1. Download the zip folder.
  2. Right click ‘extract all’ to a known location.
  3. With Dragon closed, copy/paste the ‘en-US-3-0.bdic’ file into the following folder.
    C:\Users\Username\AppData\Local\Comodo\Dragon\User Data
  4. Relaunch Dragon and see if the US spell checker will activate.

Note: Depending on how the operating system is setup, the dictionary files maybe stored at the following location.
C:\Program Files\Comodo\Dragon\Dictionaries
C:\Program Files (x86)\Comodo\Dragon\Dictionaries

Kind regards.

[attachment deleted by admin]

Hi Captainsticks. Thanks for your reply. I tried to download the zip file; but the error message stated that the download failed, due to unknown network problems. My network is working fine; as all other internet functions are working correctly. Thanks. Mr. Craig E. Whittington (Sydney NSW Australia.)

Please try clearing your browsing data and if the downloads still fail, try disabling any 3rd party extensions that you may have installed.

Thanks.

Hi again captainsticks. I did what you suggested previously; but the zip file will still not download. The same error message as previously posted here showed. Thanks. Mr. Craig E. Whittington (Sydney NSW Australia.)

Hi craig-e-whittington,
Sorry I am not sure what is happening.
Do other downloads complete?
Can you try downloading using a different browser?

Thanks.

Hi captainsticks. I was able to save the zip file to my PC hard disc. I then copied & pasted the file you suggested into the folder you suggested. Now; the ability or facility to download the spell checker is not visible. Maybe that file I copied into the above folder; is the actual spell checker. Is it? If yes; then that will explain why the above spell checker download facility is missing. Maybe now; with your supplied file the spell checker is activated as normal. What do you think? Thanks. Mr. Craig E. Whittington (Sydney NSW Australia.)

Hi Craig E. Whittington,
Yes that was the US English dictionary file used for the spell checker.

To test if US English is active, temporarily type ‘colour’ into your reply (Without posting) followed by a space.
If US English spell checker is active this should then get underlined automatically.

Hi captainsticks. I did what you suggested & yes the word ‘colour’ was automatically underlined. Another problem I am having with the same previously discussed browser is: The pages take forever or hardly ever load. I have read & followed all of the suggestions in the browser help pages; but still the pages will not load quickly. I have to constantly depress the F5 button or refresh button & then hope to get each page to load. Any suggestions? Thanks for all of your very helpful prior assistance. Mr. Craig E. Whittington (Sydney NSW Australia.)

There is some issues with the current Dragon and Adobe Flash.
Does it appear slow on all pages or only pages containing Flash content?

Has this slow loading issue only recently occurred?

Edit: I can’t help but think the download issue and the page loading issue are both possibly related issues.

Thanks.

Hi captainsticks. I have only installed the previously discussed browser 2 days ago; so the slow page loading issue has always been present. The pages seem to be slow loading all the time; whether flash is or is not activated. Your comment below about the download issue possibly related to my current slow page loading issue: All other downloads function correctly. It was only the sent zip file that would not download. I did not try to use Internet Explorer 11 as an alternative browser to download the zip file.

I am using Adobe Flash Player version 14; which is beta. Could it be this beta version causing the issue? Any other suggestions? Thanks. C.E.W.

Hi craig-e-whittington,
I do not think the Beta version of Flash would be causing any issues.
I am only stabbing in the dark, sorry.
It has been noted that security programs such as ‘Trusteer Rapport’ has caused issues with Chromium based browsers.
Do you have ‘Trusteer Rapport’ and also what other security programs do you have installed?

Thanks.

Hi captainsticks. I do not have ‘Trusteer Rapport’ security programme installed on my PC. I have Malwarebytes & ZoneAlarm PRO Firewall & Anti-Virus as security programmes installed on my PC. Any suggestions? Thanks. CEW.

Hi craig-e-whittington,
Check the logs of your security programs to make sure they are not blocking Dragon.

Try disabling ‘malware domain filtering (Comodo Secure DNS)’, found under privacy in Dragon’s advanced settings.
Try disabling ‘Use hardware acceleration when available’, found under system in Dragon’s advanced settings.
Re-enable the above settings if they don’t solve the issue.

That failing, I hope someone else has some ideas.

Kind regards.

Hi captainsticks. I did all what you recommended as below. A slight improvement was noted; but the slow page loading issue is still present. It is an intermittent issue. Also; when the page eventually does load (sometimes & as mentioned above, intermittent issue) the images on & within the page are distorted and/or missing entirely. Thanks. C.E.W.

Hi craig-e-whittington,
Sorry none of my suggestions have helped solve this issue.

A couple of more suggestions with no guarantee that they will help.
Check to see if your graphics drivers are up to date.

Try the portable version of Dragon, this may help decide whether or not that the installed version is corrupt in some way.
It will also help eliminate any user profile issues.
Note: The portable version is totally independent from the installed version.
Portable Version

Thank you for your patience and perseverance. :-TU

Is the problem with the page loading happening on all browsers? Could you test with at least one other browser?

If the problem is specific for Dragon try installing it as a portable version in another folder than your current Dragon is installed in. If the problem goes away there is a problem with the profile of your current Dragon installation.

If the problem happens with other browsers we may be looking at a network problem. In that case we need to take different angles of investigation.