LAN speed very slow in Vista, OK in XPSP2

I have the following issue with the latest CPFv3. Have it installed on XPSP2 x86 and Vista Business x64, with generally the same settings. When I copy files over LAN in XP, the speed is around the expected 10 MB/s, on Vista however, it doesn’t go faster than ~660 kB/s.

In the other 1-2 threads discussing speed issues, advanced packet analysis functions (or whatever they’re called, I mean the 4 (5?) extra options in the firewall settings, such as the fragmented packets, extra protocol analysis, etc.) were mentioned as possible causes for speed slowdown, but in my case they’re all turned on both in XP and in Vista. I’ll try different settings before giving up, but my list of programs which don’t work (correctly and without much trouble) under Vista x64 is already fairly extensive. >:(

Otherwise, (R).

Update:

I noticed, that CPF is v3.0.13 in XP, and was the latest in Vista. To eliminate these diffrences and to test some more, I tried CPF v 3.0.13.268, 3.0.14.276, and 3.0.15.277 (all x64). My Ethernet card is Marvell Yukon GBit Ethernet on an Asus P5B Deluxe. I also tested 2 different net card drivers, one supplied with Vista and the other was Marvell’s own v10.51.1.3. Oh, and the 4 miscellaneous checks (fragmented packets, etc) have been turned off before the tests.

In all cases, copying to/from network shares (net use…) was painfully slow (650-700 kB/s), even with stopped cpf service and closed application. Uninstalling CPF always solved the problem.

Keep up the good work, guys, I’m eagerly waiting for a version whithout this feature. For now, however, my Vista will remain comodo-less.

yea i have the same, using Vista64 and Opera. Defence and Security on training mode with Firewall disabled is fine, but enable Firewall and it goes boom.

Actually it’s the same with IE7, is this a known problem ? also have a Marvell Yukon NIC (saw it mentioned in another post)

  • *Note the problem is extremely (and I stress EXTREMELY) slow web browsing, anyone have any info/fix on/for this ?

that won’t help, but I’ve experienced an extremely slow transfer speed between two Vista machines, and then read in articles that it was much faster with XP installed on all networked machines. This issue I’ve had with Vista and LAN networking was without CFP (3.0 was not out and 2.4 does run in Vista).

Sounds like this is one of the three well known bugs in Vista, always due to a memory leak issue, together with having to wait for ages when deleting some files, even small, or copying files from one partition to another.

Fraid not, most of those issues are sorted with SP1, basically with CPF 3 on i get from 1 - 18kb/sec after a long wait (10-20 secs) disable firewall and I get 100+ kb/sec with no/hardly any wait, so it’s something directly CPF related, I’ve been using Vista 64 for months, and it’s fine with everything else (specially after SP1).

didn’t know SP1 got out of beta :SMLR. I was talking about Vista non-Sp1 (32 bit version). The bugs I was talking about have been experienced by millions of users and Microsoft has acknowledged there was a memory leak (and I do not belong to the users whose machine was the most affected by these bugs).

ah SP1 Beta (RC1) sorry (:CLP)
ok so it seems that really slow browsing is limited to moi, and the unlucky few, so question, is anyone running a standard cable connection with Vista64 and not having a hit on web browsing ?