LAN no longer available, despite RULES & ZONE tips

(system details listed at bottom) My LAN has disappeared after many months without problem. I’ve tried tips posted elsewhere in the forums, but nothing helps:

Network Control Rules
LAN? [RESOLVED]

My network monitor rules in comodo are the 3 basic ones (minus the bittorrent 4th) in the first link above, after adding the “trusted zone” for my lan; Windows firewall is off; All windows network-related services are running fine (as far as I can tell); and the comodo log doesn’t mention blocking anything on either computer that seems related (mostly upnp-mcast(1900) & 1026/1027 inbound packets … which seems like a good thing to me).

I still have no LAN, and no idea why, which is especially annoying since it worked fine for months … I had no trouble transferring files back & forth, running backups from one machine, etc. Now, when I try to browse the LAN in WinExplorer, I get this from both computers:


Microsoft Windows Network

Giacomo_lan is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions.

The list of servers for this workgroup is not currently available

OK

Is there a comprehensive list of dependencies, or a troubleshooting tool that can help identify what is now blocking my LAN?

Thanks for any assistance.

System Details based on Please read before posting:

DSL router, ethernet wired LAN
WinXP home sp2 with autoupdating on (logging in as an administrator, win firewall disabled, WI-FI & 1394 (firewire?) disabled)
AVG anti-virus
CPF 2.4.18.184
==> no “block” rules in App Manager
==>
http://mypage.bluewin.ch/ditommaso/hidden/networkcontrolrules.jpg

==> here I’ve first cleared the log, then tried to access the other laptop (& vice versa) then taken this snapshot … nothing at all:

http://mypage.bluewin.ch/ditommaso/hidden/emptylog.jpg

Anyone experiencing these symptoms on a WinXP sp2 system with MS Automatic Updates active should take a step back from Comodo. I’ve allowed Auto Upd to change nearly whatever it wants on my system over the weeks since my LAN last worked (including NIC drivers).

I now believe one of those MSAUs broke something invisible.

For me, I’ve just re-run the MS “Network Setup Wizard” in “My Network Places” simply out of desparation … although I expected this step to be a complete waste of timesince file/print sharing have always been activated, I’ve had zero reason to fiddle with my “workgroup” name or computer names, etc.

Nonetheless, simply rerunning the network wizard solved the problem I was trying to blame on CPF. My LAN is back.

Perhaps a useful tip/test for others with the same symptoms : I finally realized I had to look beyond CPF after unplugging the tele. line to my DSL router (but leaving the ethernet up & running). Then I disabled all unnec. apps on both computers (including all security software). That highlighted that a naked windows machine could no longer see other naked windows machines on the same exposed LAN. Apparently simply re-running the networking wizard reminded this silly alzheimerish OS that it’s actually a network-enabled OS.

(of course, don’t forget to re-enable your security software before plugging that tele. line back in :slight_smile:

Nice updates MS! (:AGY)