Kiwi CatTools 3.3.11 prevented from spawning threads by CFP (v3.0.24.368 X32)


  • AMD64 3000+/2GB RAM/80GB HD running Windows XP SP2 with all patches
  • Comodo Firewall Pro v3.0.24.368 (released 24May2008)
  • Kiwi CatTools v3.3.11 (released 28May2008)
    Kiwi CatTools | SolarWinds

My boss was still running Kerio Personal Firewall 2.1.5 and it was giving him grief. As I’d run CFP since v2.4 and really liked it, we decided to do the same for his PC. After properly uninstalling KPF, rebooting, and gutting all remnants of that program, we installed the latest release of CFP.

We did a vanilla install, allowing both F+ and D+ to be installed, though not the toolbar or extaneous stuff. After rebooting, we setup our trusted networks, etc.

All went well until we noticed that Kiwi CatTools, a program my boss depends on, wasn’t running properly. Further investigation showed that CatTools was not running threads as it usually would. (It has a small line in the status bar indicating ‘x of 10’ threads kicking off when running some of the scripts my boss has had running for years now.)

[NOTE: The architecture of CatTools is that it installs as 3 pieces: 1) an NT service launched on startup, which itself spawns threads to run 2) a client program that does the heavy work of accessing routers/hosts to pull configs, and then 3) a GUI manager that the user runs to configure/manipulate the service.]

Checking the active connections via CFP, we could see CatTools was, in fact, at least able to access the routers it was trying to backup. And syslogs from the routers told us they were being logged into. But still CatTools was not operating properly and generating the usual threads it used (and it never actually completed its task so in essence it no longer worked).

We thought it was D+ (possibly interfering as the service tried to launch/communicate with the client via DCOM or whatever mechanism it uses), so we disabled it, but no luck. Long story short, we uninstalled CFP, rebooted, and bam! CatTools was working properly again.

Making sure to clean out leftover cruft from the CFP install (folders left behind, etc.), we decided once again to try installing it. This time we installed JUST the firewall, disabling all the other options (no D+, no leak protection, etc.). After reboot and initial setup, we right away tried CatTools again. Once again, CatTools was unable to spawn threads and execute properly.

Repeatable steps:

  • install CFP v3.0.24.368
  • install Kiwi CatTools 3.3.11
  • setup job that involves multiple routers/hosts to backup configs
  • execute job and note thread count

All testing was done using an Administrator account. No, the Windows Firewall was not accidentally re-enabled (though this issue seems to have more to do with internal communications than anything network-related).

If anyone else is experiencing this issue, or has found a solution, we would sincerely appreciate hearing from you. We’re scratching our heads on this. At this point, at least temporarily, my boss has to resort to using the Windows built-in firewall. But he would clearly prefer the functionality offered by CFP if it just didn’t cripple programs he relies on.

If you need any additional information, please do not hesitate to ask. I have provided a URL to the Kiwi site in case you wish to contact their devs directly. And my boss has sent them a similar notice asking if they’ve had/heard of any issues with CatTools running with CFP from others (or vice versa, others using CFP and CatTools without issue).