Killswitch/System Information always displays 0 disk activity [V6][M642]

A. THE BUG/ISSUE (Varies from issue to issue)
[ol]- Summary - Killswitch/System Information always displays 0 disk activity.

  • Can U reproduce the problem & if so how reliably?: Yes, always.
  • If U can, exact steps to reproduce. If not, exactly what U did & what happened:
    a: open CIS main panel
    b: select Tasks
    c: select Advanced Tasks
    d: select Watch Activity
    e: in (new window) Killswitch menu bar, select View → System Information (or type Ctl-I)
    f: In (new) System Information window, select I/O tab
    g: invoke some disk intensive task (e.g CIS full virus scan)
    h: observe that Disk graph stays empty and that Disk deltas all stay 0.
    i: open Windows Task Manager → Performance tab → Resource Monitor
    j: observe lots of disk I/O.
  • If not obvious, what U expected to happen:
    Disk activity graph should show spikes, deltas should be non-zero
  • If a software compatibility problem have U tried the conflict FAQ?: no
  • Any software except CIS/OS involved? If so - name, & exact version: Windows Task manager
  • Any other information, eg your guess at the cause, how U tried to fix it etc:
    It looks to me like System Information is not collecting Disk info

B. YOUR SETUP (Likely the same for each issue, so you can copy forward)
[ol]- Exact CIS version & configuration: CIS & Killswitch both are v 6.3.294583.2937

  • Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV: all
  • Have U made any other changes to the default config? (egs here.): no
  • Have U updated (without uninstall) from a CIS 5?: no: uninstalled CIS 6.2, then installed CIS 6.3
    [li]if so, have U tried a a clean reinstall - if not please do?: done
    [/li]- Have U imported a config from a previous version of CIS: no
    [li]if so, have U tried a standard config - if not please do:
    [/li]- OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
    Windows 7 Pro, SP1, 64 bit, UAC on, privileged, no Vmachine.
  • Other security/s’box software a) currently installed b) installed since OS: no

Full screengrab attached, annotated with outlines of disk statistics.

Edited to add:

  1. killswitch Current View (zipped)
  2. a screen grab showing the attached disks. Note that F: is a RAMDisk, using Dataram Inc’s freeware RAMDisk driver v3.5.130.0 (5/5/2011) Might that cause confusion? (There was no I/O being done to it.)

Edited to add:
3. Comodo diagnostics file CisReport_v6.3…
4. further info:
I deinstalled Ramdisk, rebooted, and ran the test scenario again. Still no disk i/o shown.
I installed the most recent version of Ramdisk (v4.3.0.1), rebooted, and ran the test again. Still no disk i/o shown.

[attachment deleted by admin]

Please create a diagnostics report while the full scan is running and attach it to your first post.

Also, please select the option to “Save Current View” through KillSwitch during the scan, put this in a zip file, and attach it to your first post as well.

I cannot replicate this on my computer. Thus, the devs will need this information in order to replicate, and then fix, this issue.

Let me know if you have any questions.


PM reminder sent.

I’m sorry, I don’t know what you mean by “diagnostics report”. Is there a particular file you want?
The full scan found 0 threats, if that’s what you mean.

I reproduced the problem again (after rebooting to ensure a minimum number of jobs running),
and used KillSwitch’s “Save current view” menu option.
I’ve zipped the killswitch output and attached it to the initial post.

[attachment deleted by admin]

Thank you. That is indeed one of the file I was asking for.

To create the diagnostics report open the main CIS GUI. Then click on the question mark icon near the upper right side of the GUI and select support. Then select Diagnostics. After it checks it will give you the option to create a diagnostics report. Tell it to do this. Then attach the zip file it creates to your first post.

Once you have done that, or if you have any questions, let me know so I can forward this to the devs.


I’ve attached the diagnostic output file that you described.

I also tested without and then with an updated ramdisk. No change in symptom.

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again.

Please try to start killswitch as administrator.

Running KillSwitch as administrator does allow it to display the disk I/O activity.
(Screenshot attached.)

Of course, it’s important that it be able to show this information for non-privileged users who don’t have admin privileges.

[attachment deleted by admin]

THanks for your reply.
For non-admin users,Killswitch is running without admin privileges,so it cannot show the disk I/O ,now we can see the disk I/O information is a bug, we will fix it in the latest version.
While Microsoft Taskmanager is running with admin privileges, run as admin is also not pop UAC,so it can display disk I/O.

The devs have informed me that they believe that this is fixed for CIS version 7.0.313494.4115. I will therefore move this to Resolved.

If this is still not fixed for you please both respond to this topic and send me a PM (including a link to this bug report).

Thank you.