KillSwitch no longer works as Task Manager replacement.


Recently I’ve noticed that when I press CTRL + SHIFT + ESC KillSwitch isn’t launched, I get the busy/waiting cursor thingy but then nothing happens, same thing when trying to go through CTRL + ALT + DEL and then Task Manager, but it DOES work when right-clicking the task bar and then clicking Task Manager.

I’ve tried disabling Task Manager replacement and then the normal Task Manager launches without issue but then when I make KillSwitch replace the Task Manager the issue comes that I can’t launch it with the methods detailed above, it used to work before but now doesn’t.

I’m not sure what has gone wrong or how to fix it, help? =S

Also, I’m not sure if this topic should be here or in the CCE part of the forums, thinking since it comes with CIS I’ll just make the thread here and then if it’s wrong then a mod can move it.

Sanya IV Litvyak

An update, using KillSwitch I can see that whenever I do CTRL+Alt+Del and click Task Manager, it launches LaunchTM.exe which in turn launches killswitch.exe but that killswitch process only uses 68 KB of RAM in contrast to the ~46,000 KB of RAM the working killswitch process is using and the non working killswitch executable stays there not doing anything.

I just found why although I don’t understand why this issue presented itself first now.

It’s because I have set killswitch.exe to be started as administrator in the properties… when I disable that it launches fine but with it enabled it does not launch fine… Used to work fine before though…

I just tried it with Process Hacker and that starts normally when I set it to always run as administrator.